summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-04-03 07:23:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-04-03 07:23:59 +0000
commite5e885948d29bdc26c4e2afc9d27e0fc78628a78 (patch)
tree86b2ec00d0f759072bae5cb640d335eee10fff71 /net-www/apache/apache-2.0.49.ebuild
parentstable on ppc (diff)
downloadhistorical-e5e885948d29bdc26c4e2afc9d27e0fc78628a78.tar.gz
historical-e5e885948d29bdc26c4e2afc9d27e0fc78628a78.tar.bz2
historical-e5e885948d29bdc26c4e2afc9d27e0fc78628a78.zip
fix bug #46585.
Diffstat (limited to 'net-www/apache/apache-2.0.49.ebuild')
-rw-r--r--net-www/apache/apache-2.0.49.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-www/apache/apache-2.0.49.ebuild b/net-www/apache/apache-2.0.49.ebuild
index 66dd8d7d0a3d..fb453934f46e 100644
--- a/net-www/apache/apache-2.0.49.ebuild
+++ b/net-www/apache/apache-2.0.49.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49.ebuild,v 1.8 2004/04/02 23:26:52 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49.ebuild,v 1.9 2004/04/03 07:23:59 robbat2 Exp $
inherit flag-o-matic eutils
@@ -158,6 +158,11 @@ src_compile() {
echo 'ac_cv_header_netinet_sctp_h=${ac_cv_header_netinet_sctp_h=no}' >> ${S}/config.cache
echo 'ac_cv_header_netinet_sctp_uio_h=${ac_cv_header_netinet_sctp_uio_h=no}' >> ${S}/config.cache
+ # fix bug #46585
+ CFLAGS="`echo ${CFLAGS} | xargs`"
+ CXXFLAGS="`echo ${CXXFLAGS} | xargs`"
+ LDFLAGS="`echo ${LDFLAGS} | xargs`"
+
SSL_BASE="SYSTEM" \
./configure \
--with-suexec-safepath="/usr/local/bin:/usr/bin:/bin" \