summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2012-07-21 22:14:58 +0000
committerMatt Thode <prometheanfire@gentoo.org>2012-07-21 22:14:58 +0000
commit0898e3535a3ad8da964bdb3d260c3d36ba003e2d (patch)
tree3ce78fc5d354529aede5aa3d7bdcdd27307cb5d1 /net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild
parentmarked x86 per bug 427522 (diff)
downloadhistorical-0898e3535a3ad8da964bdb3d260c3d36ba003e2d.tar.gz
historical-0898e3535a3ad8da964bdb3d260c3d36ba003e2d.tar.bz2
historical-0898e3535a3ad8da964bdb3d260c3d36ba003e2d.zip
adding support for newer hardware (ex bcm4311) thanks to avx (idevelop@ph030.de) for the ebuild
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild')
-rw-r--r--net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild b/net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild
new file mode 100644
index 000000000000..3e676aa062bc
--- /dev/null
+++ b/net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/b43-firmware/b43-firmware-5.100.138.ebuild,v 1.1 2012/07/21 22:14:58 prometheanfire Exp $
+
+: ${B43_FIRMWARE_SRC_OBJ:=wl_apsta.o}
+
+MY_P="broadcom-wl-${PV}"
+DESCRIPTION="broadcom firmware for b43 LP PHY and >=linux-3.2"
+HOMEPAGE="http://linuxwireless.org/en/users/Drivers/b43"
+SRC_URI="http://www.lwfinger.com/b43-firmware/${MY_P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="b43"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror binchecks strip"
+
+DEPEND=">=net-wireless/b43-fwcutter-015"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ mkdir ebuild-output
+ b43-fwcutter -w ebuild-output $(find -name ${B43_FIRMWARE_SRC_OBJ}) || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r ebuild-output/* || die
+}