summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-28 03:36:35 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-28 03:36:35 +0000
commit814ba6559f314c479340e5e19735a32fce521d86 (patch)
treedf9d334fee99dfa24f1f671e7b68d3a8f8e935fc /net-print/hp-web-jetadmin
parentlibesmtp 0.8.5-pre3... a dependency for balsa (diff)
downloadhistorical-814ba6559f314c479340e5e19735a32fce521d86.tar.gz
historical-814ba6559f314c479340e5e19735a32fce521d86.tar.bz2
historical-814ba6559f314c479340e5e19735a32fce521d86.zip
A web version of HP's Jetadmin software package, typically used on NT
administrator's workstations. This is a neat piece of software, and I've used it in the past on corporate networks for managing printer firmware and queues, etc.. But I have to honestly say that HP's self-extracting install program sucks. Also the whole binary-only package thing bugs me. But its a nice addition for Gentoo Linux. I hope! :) I could use suggestions for improving it. Enjoy. --Donny
Diffstat (limited to 'net-print/hp-web-jetadmin')
-rw-r--r--net-print/hp-web-jetadmin/files/20hpwebjetadmin1
-rw-r--r--net-print/hp-web-jetadmin/files/digest-hp-web-jetadmin-6.57
-rw-r--r--net-print/hp-web-jetadmin/files/etc.redhat-release1
-rw-r--r--net-print/hp-web-jetadmin/files/hpwebjetd-6.5.rc617
-rw-r--r--net-print/hp-web-jetadmin/hp-web-jetadmin-6.5.ebuild128
5 files changed, 154 insertions, 0 deletions
diff --git a/net-print/hp-web-jetadmin/files/20hpwebjetadmin b/net-print/hp-web-jetadmin/files/20hpwebjetadmin
new file mode 100644
index 000000000000..6c6a65dce492
--- /dev/null
+++ b/net-print/hp-web-jetadmin/files/20hpwebjetadmin
@@ -0,0 +1 @@
+LDPATH=/opt/hp-web-jetadmin-6.5
diff --git a/net-print/hp-web-jetadmin/files/digest-hp-web-jetadmin-6.5 b/net-print/hp-web-jetadmin/files/digest-hp-web-jetadmin-6.5
new file mode 100644
index 000000000000..23198a9dcdf5
--- /dev/null
+++ b/net-print/hp-web-jetadmin/files/digest-hp-web-jetadmin-6.5
@@ -0,0 +1,7 @@
+MD5 d6f4116fd16f084dde6b8195e36c2f81 bpj06492.pdf
+MD5 24ff66aadffc605347b8fe532bee1b23 hpwebjet_linux.selfx
+MD5 e1059f4c0f3d12a237638b924905c107 wjaen_readme.txt
+MD5 d04bdbd82961d090f44d9e70789bab4b wjainfo_pps.html
+MD5 24a35a0567702b3a19956b42b9e710f2 wjainfo_rda.html
+MD5 f8b08976d71164a934648109729fce84 wjapps_linux_bundle.fpb
+MD5 9d2bb37af088571eb0366cd154316964 wjarda_linux_bundle.fpb
diff --git a/net-print/hp-web-jetadmin/files/etc.redhat-release b/net-print/hp-web-jetadmin/files/etc.redhat-release
new file mode 100644
index 000000000000..151394e7f20f
--- /dev/null
+++ b/net-print/hp-web-jetadmin/files/etc.redhat-release
@@ -0,0 +1 @@
+Red Hat Linux release 7.1 something
diff --git a/net-print/hp-web-jetadmin/files/hpwebjetd-6.5.rc6 b/net-print/hp-web-jetadmin/files/hpwebjetd-6.5.rc6
new file mode 100644
index 000000000000..4781bfef5cdf
--- /dev/null
+++ b/net-print/hp-web-jetadmin/files/hpwebjetd-6.5.rc6
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting HP Web JetAdmin"
+ start-stop-daemon --start --quiet --exec /opt/hp-web-jetadmin-6.5/hpwebjetd -- -start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping HP Web JetAdmin"
+ start-stop-daemon --stop --quiet --exec /opt/hp-web-jetadmin-6.5/hpwebjetd -- -stop
+ eend $?
+}
diff --git a/net-print/hp-web-jetadmin/hp-web-jetadmin-6.5.ebuild b/net-print/hp-web-jetadmin/hp-web-jetadmin-6.5.ebuild
new file mode 100644
index 000000000000..4a406a42f289
--- /dev/null
+++ b/net-print/hp-web-jetadmin/hp-web-jetadmin-6.5.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-print/hp-web-jetadmin/hp-web-jetadmin-6.5.ebuild,v 1.1 2001/09/28 03:36:35 woodchip Exp $
+
+# *** README ***
+#
+# This package, in its most basic form (no optional components) will install
+# some 4300 files, totalling some 45MB. According to HP the minimum system
+# requirements are a 400MHz CPU with 128MB RAM. Note that this uses HP's own
+# self-extracting program to install to gentoo's tempdir, during which it
+# runs some tests. It will _appear_ like its stuck, but its not. Please be
+# patient and wait for it to completely merge. You might see some funny
+# debugging information, which potentially looks like an error message.
+# Dont worry about that, just ignore it. Furthermore, this package installs
+# a whole truckload of doc files into /opt/hp-web-jetadmin/doc, totalling
+# some 34MB. The daemon even writes configuration info into that directory
+# which you'll notice if you play around with the program, and then unmerge
+# it. All in all, its a nice program, if somewhat cluttered and clumsy.
+#
+# I probably need to tweak the depends a little; I couldn't make it install
+# on an rc5 box with no X. For the love of Joe, I hope this program doesn't
+# require X to install! It sure shouldn't need it to run. Consider this a
+# rant on a large vendor's idea of 'supporting Linux'. Im my opinion, too
+# many vendors are providing binary-only packages/drivers that are simply
+# "not acceptable". They wouldn't pass QA inside of their own organisations
+# most likely. Quite frankly, the situation is basically pathetic, and I
+# now can sympathise with Alan Cox, who refuses to even entertain queries
+# on binary-only drivers. </soapbox>
+#
+# If you can help with the depends, or make any other suggestions for this
+# glorius package, feel free.
+#
+# *** README ***
+
+DESCRIPTION="Remotely install, monitor, and troubleshoot network-connected printers"
+HOMEPAGE="http://www.hp.com/go/webjetadmin/"
+#
+# Hey! These files total 30MB! Biggest one is hpwebjet_linux.selfx, which is 20MB!
+# When we get dependency support for SRC_URI, this can be spiffed up a little bit.
+# For the time being, if you really wanted to, you could remove stuff from SRC_URI
+# below then rebuild the digest by doing: ebuild hp-web-jetadmin-6.5.ebuild digest
+#
+# The .fpb files are optional components, and total just over 8MB:
+# o wjarda_linux_bundle.fpb: HP Remote Discovery Agent Component
+# o wjapps_linux_bundle.fpb: HP Web Print Server Manager Bundle
+#
+SRC_URI="http://ftp.hp.com/pub/networking/software/hpwebjet_linux.selfx
+ http://ftp.hp.com/pub/networking/software/wjaen_readme.txt
+ http://www.hp.com/cposupport/manual_set/bpj06492.pdf
+ http://www.hp.com/pond/wja/live/manual/html/wjainfo_rda.html
+ http://www.hp.com/pond/wja/live/manual/bundles/wjarda_linux_bundle.fpb
+ http://www.hp.com/pond/wja/live/manual/html/wjainfo_pps.html
+ http://www.hp.com/pond/wja/live/manual/bundles/wjapps_linux_bundle.fpb"
+DEPEND="virtual/glibc"
+
+src_unpack() { :; } ; src_compile() { :; }
+
+src_install() {
+ chmod 755 ${DISTDIR}/hpwebjet_linux.selfx
+
+ #
+ # Won't install without this hack -- cmon HP you can do better
+ # than this. This is really sad. If you donate to me a decent
+ # enough printer, I'll do QA/testing for you! :)
+ #
+ install -m 644 ${FILESDIR}/etc.redhat-release /etc/redhat-release
+
+ #
+ # The self-extracting installation program tries to get your
+ # hostname automatically. It also configures itself by default
+ # to use tcp/8000 unless its already in use by something else.
+ # You can change those by supplying the following arguments to
+ # the command below if you really want to:
+ #
+ # -m <name> Sets the hostname to <name> if <name> is valid
+ # -p <num> Sets the port number to <num> if <num> is valid
+ #
+ # You can change the port in /opt/hp-web-jetadmin/httpd.ini
+ # after installing. Maybe the hostname can be changed too.
+ #
+ ${DISTDIR}/hpwebjet_linux.selfx -s -d ${D}/opt/hp-web-jetadmin-6.5
+
+ #
+ # /etc/init.d/hpwebjetd (not in $D) is getting installed by
+ # this wonderful self-extracting program. I'd rather remove
+ # it now, so a better one can be dropped in without forcing
+ # the admin to do the ._cfg tango unconditionally. Man this
+ # whole thing is turning out to be a pretty ugly affair.
+ #
+ rm -f /etc/init.d/hpwebjetd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/hpwebjetd-6.5.rc6 hpwebjetd
+
+ #
+ # This lets you start the daemon from anywhere, rather than
+ # making you cd to /opt/hp-web-jetadmin.
+ #
+ insinto /etc/env.d ; doins ${FILESDIR}/20hpwebjetadmin
+
+ #
+ # Some docs. Not ideal I know, but at least its something.
+ #
+ dodoc ${DISTDIR}/wjaen_readme.txt
+ dodoc ${DISTDIR}/bpj06492.pdf
+ dodoc ${DISTDIR}/wjainfo_rda.html
+ dodoc ${DISTDIR}/wjainfo_pps.html
+
+ #
+ # Butcher alert -- this is completely ridiculous. Ciao baby.
+ #
+ rm -f /etc/redhat-release
+}
+
+#
+# TODO:
+#
+# o I havent gotten around to working in the optional components
+# yet, but those are next. Im commiting it now so that anybody
+# interested can try it out.
+#
+# o Maybe leave the /etc/redhat-release file alone (permanently
+# install it) or add some code in src_install to check for it,
+# back it up if there, drop in our file, install, then move
+# the backup back. I dont see the need for this nonsense. Why
+# cant vendors just say you need libc this, ssl that, libfoo
+# this and libbar that. This just makes them look like aloof
+# butchers if you ask me. Nonsense.
+#