summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-08-19 03:41:41 +0000
committerJon Hood <squinky86@gentoo.org>2004-08-19 03:41:41 +0000
commitfea379f6913611b95190dcbe151c52256ca9765f (patch)
tree8b8625a53b11e80efc6fb193bc3d1c3f52f9e228 /net-p2p/giftui
parentstable on ppc64 (diff)
downloadhistorical-fea379f6913611b95190dcbe151c52256ca9765f.tar.gz
historical-fea379f6913611b95190dcbe151c52256ca9765f.tar.bz2
historical-fea379f6913611b95190dcbe151c52256ca9765f.zip
updating the patch for more debugging features
Diffstat (limited to 'net-p2p/giftui')
-rw-r--r--net-p2p/giftui/ChangeLog6
-rw-r--r--net-p2p/giftui/Manifest15
-rw-r--r--net-p2p/giftui/files/0.4.1-gentoo.patch27
-rw-r--r--net-p2p/giftui/giftui-0.4.1.ebuild4
4 files changed, 47 insertions, 5 deletions
diff --git a/net-p2p/giftui/ChangeLog b/net-p2p/giftui/ChangeLog
index 5bef359c7bb0..bf6526eb4934 100644
--- a/net-p2p/giftui/ChangeLog
+++ b/net-p2p/giftui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/giftui
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftui/ChangeLog,v 1.15 2004/08/08 17:53:56 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftui/ChangeLog,v 1.16 2004/08/19 03:41:41 squinky86 Exp $
+
+ 18 Aug 2004; Jon Hood <squinky86@gentoo.org> +files/0.4.1-gentoo.patch,
+ giftui-0.4.1.ebuild:
+ Updating the patch for more stability and debugging features.
08 Aug 2004; Jon Hood <squinky86@gentoo.org> giftui-0.4.1.ebuild:
Use the correct docs dir irt #46565.
diff --git a/net-p2p/giftui/Manifest b/net-p2p/giftui/Manifest
index eaa9619f4ed0..fe70c77e59a0 100644
--- a/net-p2p/giftui/Manifest
+++ b/net-p2p/giftui/Manifest
@@ -1,7 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 592564b6ba70078c49731e5bb3d98cc1 giftui-0.3.1.ebuild 576
-MD5 797b86061244d562c5f2c9ada133ddd4 giftui-0.4.1.ebuild 955
-MD5 7c46799ae621ba968bc125e77afd117f ChangeLog 1866
+MD5 fbdc1ad3b7880016ae03e73f74a8563b giftui-0.4.1.ebuild 962
+MD5 9eba7956c0afc28239a434ab0f302f69 ChangeLog 2028
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 40bfcba195763791682cf11aef06f32a files/0.4.1-gentoo.patch 580
MD5 99a230235e2682c6f55c7b129bf8d395 files/digest-giftui-0.3.1 65
MD5 50756165a3e142ab3ee5f305751f126e files/digest-giftui-0.4.1 65
MD5 36442a789cd241e3147198c3a1076c08 files/main.c.diff 503
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBJCF4cAgAdbxYsnERAo6nAJ0SBSc7kZRvK0dlPWjnUPA777qO6wCfVwb9
+d9iIdVcmaUDq5UgBYoJryRQ=
+=Tlv9
+-----END PGP SIGNATURE-----
diff --git a/net-p2p/giftui/files/0.4.1-gentoo.patch b/net-p2p/giftui/files/0.4.1-gentoo.patch
new file mode 100644
index 000000000000..7b910b7e08f4
--- /dev/null
+++ b/net-p2p/giftui/files/0.4.1-gentoo.patch
@@ -0,0 +1,27 @@
+diff -Naur giftui-0.4.1/src/main.c giftui-0.4.1.new/src/main.c
+--- giftui-0.4.1/src/main.c 2004-05-06 01:55:02.000000000 -0500
++++ giftui-0.4.1.new/src/main.c 2004-08-18 22:30:08.600960640 -0500
+@@ -197,6 +197,12 @@
+ bindtextdomain (PACKAGE, LOCALEDIR);
+ textdomain (PACKAGE);
+ #endif
++
++ /* init GObject system */
++ g_type_init ();
++
++ /* GTK+ init */
++ gtk_init (&argc, &argv);
+
+ /* configuration init & load */
+ giftui_config_init ();
+@@ -214,10 +220,6 @@
+
+ return EXIT_FAILURE;
+ }
+-
+-
+- /* GTK+ init */
+- gtk_init (&argc, &argv);
+
+ return EXIT_SUCCESS;
+ }
diff --git a/net-p2p/giftui/giftui-0.4.1.ebuild b/net-p2p/giftui/giftui-0.4.1.ebuild
index 0dceddf6d731..3290570ad17e 100644
--- a/net-p2p/giftui/giftui-0.4.1.ebuild
+++ b/net-p2p/giftui/giftui-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftui/giftui-0.4.1.ebuild,v 1.7 2004/08/08 17:56:13 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftui/giftui-0.4.1.ebuild,v 1.8 2004/08/19 03:41:41 squinky86 Exp $
inherit gnome2 eutils
@@ -24,7 +24,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/main.c.diff
+ epatch ${FILESDIR}/${PV}-gentoo.patch
sed -i -e 's:/doc/giftui:/share/doc/${P}:g' Makefile*
export WANT_AUTOMAKE=1.7
export WANT_AUTOCONF=2.5