summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-17 17:36:55 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-17 17:36:55 +0000
commite4e05ef87035c1840f0f4345d28b10ee77ef57e1 (patch)
treed3e2afb1502184fe6bad1e6f2389619b8cc19308 /net-nds
parentold (diff)
downloadhistorical-e4e05ef87035c1840f0f4345d28b10ee77ef57e1.tar.gz
historical-e4e05ef87035c1840f0f4345d28b10ee77ef57e1.tar.bz2
historical-e4e05ef87035c1840f0f4345d28b10ee77ef57e1.zip
Version bump #255199 by Chi-Thanh Christopher Nguyen.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog9
-rw-r--r--net-nds/rpcbind/rpcbind-0.1.7.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index 294a44c8bbe2..6823c6c63f06 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/rpcbind
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.2 2008/12/06 11:29:10 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.3 2009/01/17 17:36:55 vapier Exp $
+
+*rpcbind-0.1.7 (17 Jan 2009)
+
+ 17 Jan 2009; Mike Frysinger <vapier@gentoo.org> +rpcbind-0.1.7.ebuild:
+ Version bump #255199 by Chi-Thanh Christopher Nguyen.
*rpcbind-0.1.5.1 (06 Dec 2008)
diff --git a/net-nds/rpcbind/rpcbind-0.1.7.ebuild b/net-nds/rpcbind/rpcbind-0.1.7.ebuild
new file mode 100644
index 000000000000..abdc54b7bf4b
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.1.7.ebuild,v 1.1 2009/01/17 17:36:55 vapier Exp $
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
+ inherit autotools git
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD sun-rpc"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-libs/libtirpc"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ eautoreconf
+ else
+ unpack ${A}
+ cd "${S}"
+ # fix busted timestamps
+ find . -type f -print0 | xargs -0 touch -r .
+ fi
+}
+
+src_compile() {
+ econf --bindir=/sbin || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ doman man/rpc{bind,info}.8
+ dodoc AUTHORS ChangeLog NEWS README
+ newinitd "${FILESDIR}"/rpcbind.initd rpcbind || die
+ newconfd "${FILESDIR}"/rpcbind.confd rpcbind || die
+}