summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-08 01:58:13 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-08 01:58:13 +0000
commit10f0f232a9b87d5949a3d0ebdca95e17ec33f1ec (patch)
tree203dd4268c9c76fee7ebc18d70a2e06540306221 /net-nds
parent*** empty log message *** (diff)
downloadhistorical-10f0f232a9b87d5949a3d0ebdca95e17ec33f1ec.tar.gz
historical-10f0f232a9b87d5949a3d0ebdca95e17ec33f1ec.tar.bz2
historical-10f0f232a9b87d5949a3d0ebdca95e17ec33f1ec.zip
*** empty log message ***
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/digest-openldap-1.2.121
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.111
-rw-r--r--net-nds/openldap/openldap-1.2.12.ebuild70
-rw-r--r--net-nds/openldap/openldap-2.0.11.ebuild83
4 files changed, 155 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-1.2.12 b/net-nds/openldap/files/digest-openldap-1.2.12
new file mode 100644
index 000000000000..6014d00d1214
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-1.2.12
@@ -0,0 +1 @@
+MD5 93e5113ec65f207a6e5015fdf216c7d2 openldap-1.2.12.tgz
diff --git a/net-nds/openldap/files/digest-openldap-2.0.11 b/net-nds/openldap/files/digest-openldap-2.0.11
new file mode 100644
index 000000000000..9199e0b0baa0
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.11
@@ -0,0 +1 @@
+MD5 e51b06374012b9e7077e1f3e9f65ccd0 openldap-2.0.11.tgz
diff --git a/net-nds/openldap/openldap-1.2.12.ebuild b/net-nds/openldap/openldap-1.2.12.ebuild
new file mode 100644
index 000000000000..5debe7240673
--- /dev/null
+++ b/net-nds/openldap/openldap-1.2.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.12.ebuild,v 1.1 2001/06/08 01:58:13 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${A}"
+
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+ if [ "`use tcpd`" ] ; then
+ myconf="--enable-wrappers"
+ fi
+ if [ "`use gdbm`" ] ; then
+ myconf="$myconf --enable-ldbm --with-ldbm-api=gdbm"
+ else
+ myconf="$myconf --disable-ldbm"
+ fi
+ ./configure --host=${CHOST} --enable-passwd \
+ --enable-shell --enable-shared --enable-static \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
+ --mandir=/usr/share/man --libexecdir=/usr/lib $myconf
+ try make depend
+ try make
+ cd tests
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man libexecdir=${D}/usr/lib install
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
+}
+
+
+
+
+
diff --git a/net-nds/openldap/openldap-2.0.11.ebuild b/net-nds/openldap/openldap-2.0.11.ebuild
new file mode 100644
index 000000000000..7dbacbf0da2e
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.11.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.11.ebuild,v 1.1 2001/06/08 01:58:13 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+
+src_compile() {
+ local myconf
+ if [ "`use tcpd`" ] ; then
+ myconf="--enable-wrappers"
+ fi
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --with-tls"
+ else
+ myconf="$myconf --without-tls"
+ fi
+ if [ "`use readline`" ] ; then
+ myconf="$myconf --with-readline"
+ else
+ myconf="$myconf --without-readline"
+ fi
+ if [ "`use gdbm`" ] ; then
+ myconf="$myconf --enable-ldbm --with-ldbm-api=gdbm"
+ else
+ myconf="$myconf --disable-ldbm"
+ fi
+ try ./configure --host=${CHOST} --enable-passwd \
+ --enable-shell --enable-shared --enable-static --enable-ipv6 \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state \
+ --mandir=/usr/share/man --libexecdir=/usr/li$myconf
+ try make depend
+ try make
+ cd tests
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/usr sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state mandir=${D}/usr/share/man libexecdir=${D}/usr/lib install
+ prepman
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ dosed $i
+ done
+
+}
+
+
+
+
+
+