summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-02-09 12:43:35 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-02-09 12:43:35 +0000
commit5f45b1176a4b83f4635191dd339078fc87102ffc (patch)
treedb104e8bee12771a4e2781c52e8af7a8aa13ae5f /net-misc
parentCleanup of old ebuilds + added SLOT + closed bug #422 (diff)
downloadhistorical-5f45b1176a4b83f4635191dd339078fc87102ffc.tar.gz
historical-5f45b1176a4b83f4635191dd339078fc87102ffc.tar.bz2
historical-5f45b1176a4b83f4635191dd339078fc87102ffc.zip
initial ebuild, added SLOT
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gtkhx/files/digest-gtkhx-0.9.11
-rw-r--r--net-misc/gtkhx/gtkhx-0.9.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/gtkhx/files/digest-gtkhx-0.9.1 b/net-misc/gtkhx/files/digest-gtkhx-0.9.1
new file mode 100644
index 000000000000..1024d32624da
--- /dev/null
+++ b/net-misc/gtkhx/files/digest-gtkhx-0.9.1
@@ -0,0 +1 @@
+MD5 4fead053517c9ba58fb68ab18ecb5d11 gtkhx-0.9.1.tar.gz 543849
diff --git a/net-misc/gtkhx/gtkhx-0.9.1.ebuild b/net-misc/gtkhx/gtkhx-0.9.1.ebuild
new file mode 100644
index 000000000000..9056eabd3a4f
--- /dev/null
+++ b/net-misc/gtkhx/gtkhx-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Michael M Nazaroff <naz@themoonsofjupiter.net>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gtkhx/gtkhx-0.9.1.ebuild,v 1.1 2002/02/09 12:43:35 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a GTK+ Hotline Client based off of Hx"
+SRC_URI="http://gtkhx.sourceforge.net/files/gtkhx-0.9.1.tar.gz"
+HOMEPAGE="http://gtkhx.sourceforge.net/index.html"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-libs/gtk+-1.2.10"
+
+RDEPEND="$DEPEND"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dohtml doc/*.html
+ dodoc doc/AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+