summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-31 21:11:52 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-31 21:11:52 +0000
commit29010dd3f6af4f9a2741f5c0c79a5684e5db8027 (patch)
treec48585c79162e0ec084a11ea2bc12ccdf5142c95 /net-misc
parentand the patch itsself (diff)
downloadhistorical-29010dd3f6af4f9a2741f5c0c79a5684e5db8027.tar.gz
historical-29010dd3f6af4f9a2741f5c0c79a5684e5db8027.tar.bz2
historical-29010dd3f6af4f9a2741f5c0c79a5684e5db8027.zip
New version
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/firestarter/ChangeLog5
-rw-r--r--net-misc/firestarter/files/digest-firestarter-0.9.11
-rw-r--r--net-misc/firestarter/firestarter-0.9.1.ebuild41
3 files changed, 46 insertions, 1 deletions
diff --git a/net-misc/firestarter/ChangeLog b/net-misc/firestarter/ChangeLog
index a3f4bae8fd4e..ef67e4ba30d5 100644
--- a/net-misc/firestarter/ChangeLog
+++ b/net-misc/firestarter/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for net-misc/firestarter
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Author: Jos� Alberto Su�rez L�pez <bass@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/firestarter/ChangeLog,v 1.10 2002/12/17 19:44:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/firestarter/ChangeLog,v 1.11 2003/01/31 21:11:52 foser Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*firestarter-0.9.1 (31 Jan 2003)
+ 31 Jan 2003; foser <foser@gentoo.org> firestarter-0.9.1.ebuild :
+ New gnome2 release
*firestarter-0.8.3 (15 Oct 2002)
diff --git a/net-misc/firestarter/files/digest-firestarter-0.9.1 b/net-misc/firestarter/files/digest-firestarter-0.9.1
new file mode 100644
index 000000000000..56ab7de1427f
--- /dev/null
+++ b/net-misc/firestarter/files/digest-firestarter-0.9.1
@@ -0,0 +1 @@
+MD5 d2b2b22182a340e2bd06a94d4800d26c firestarter-0.9.1.tar.gz 628274
diff --git a/net-misc/firestarter/firestarter-0.9.1.ebuild b/net-misc/firestarter/firestarter-0.9.1.ebuild
new file mode 100644
index 000000000000..f44ee0fbee71
--- /dev/null
+++ b/net-misc/firestarter/firestarter-0.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/firestarter/firestarter-0.9.1.ebuild,v 1.1 2003/01/31 21:11:52 foser Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gui for iptables firewall setup and monitor."
+SRC_URI="mirror://sourceforge/firestarter/${P}.tar.gz"
+HOMEPAGE="http://firestarter.sf.net"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnome-2
+ sys-apps/iptables"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.21"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall destdir=${D} graphicsdir=${D}/usr/share/pixmaps || die "einstall failed"
+ dodoc AUTHORS Changelog COPYING CREDITS INSTALL README TODO
+}
+
+pkg_postinstall() {
+ ./postinstall
+}