summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-07 08:09:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-07 08:09:42 +0000
commita8c837b010be3dae5abace28e3f3084dc500bb06 (patch)
treeb71d6b342f8d99b712468b31c94388662a9fa7f0 /net-misc/proxyper/proxyper-341a.ebuild
parentversion bump. x86 stable on 335. QA cleanup. (diff)
downloadhistorical-a8c837b010be3dae5abace28e3f3084dc500bb06.tar.gz
historical-a8c837b010be3dae5abace28e3f3084dc500bb06.tar.bz2
historical-a8c837b010be3dae5abace28e3f3084dc500bb06.zip
move from app-misc/proxyper
Diffstat (limited to 'net-misc/proxyper/proxyper-341a.ebuild')
-rw-r--r--net-misc/proxyper/proxyper-341a.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/proxyper/proxyper-341a.ebuild b/net-misc/proxyper/proxyper-341a.ebuild
new file mode 100644
index 000000000000..99d7a4b0f423
--- /dev/null
+++ b/net-misc/proxyper/proxyper-341a.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxyper/proxyper-341a.ebuild,v 1.1 2004/06/07 08:09:41 dragonheart Exp $
+
+DESCRIPTION="distributed.net personal proxy"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI="http://http.distributed.net/pub/dcti/${PN}/${PN}${PV}-linux-x86-uclibc.tar.gz"
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+IUSE=""
+DEPEND=""
+RDEPEND="net-misc/host"
+
+S="${WORKDIR}/${PN}${PV}-linux-x86-uclibc"
+
+RESTRICT="nomirror"
+
+src_install() {
+ local DESTDIR="/opt/proxyper"
+ exeinto ${DESTDIR} ; doexe proxyper
+
+ # don't clobber an already existing ini file!
+ insinto ${DESTDIR}
+ if [ ! -f ${DESTDIR}/proxyper.ini ]
+ then
+ doins proxyper.ini
+ else
+ newins ${DESTDIR}/proxyper.ini proxyper.ini
+ fi
+
+ dodoc ChangeLog.txt
+ dohtml manual.html
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/proxyper.init proxyper
+}
+
+pkg_postinst() {
+ einfo "Don't forget to modify the config file"
+ einfo "located in /opt/proxyper/proxyper.ini"
+ einfo "It's recommend to reading the manual first :-)"
+}
+
+pkg_postrm() {
+ local DESTDIR="/opt/proxyper"
+ if [ -d ${DESTDIR} ]; then
+ einfo "All files have not been removed from ${DESTDIR}"
+ fi
+}