summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-19 03:32:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-19 03:32:26 +0000
commitf9f09f48dd1160a8e34c63c56cd1b62bf22ebcd3 (patch)
tree0d14a45299e3ee93a4347aa4bedff53b179155e8 /net-misc/openssh/openssh-4.0_p1-r2.ebuild
parentversion bump with patch from fabien Zouaoui via bug #104625 (diff)
downloadhistorical-f9f09f48dd1160a8e34c63c56cd1b62bf22ebcd3.tar.gz
historical-f9f09f48dd1160a8e34c63c56cd1b62bf22ebcd3.tar.bz2
historical-f9f09f48dd1160a8e34c63c56cd1b62bf22ebcd3.zip
Move default xauth location to /usr/bin/xauth.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'net-misc/openssh/openssh-4.0_p1-r2.ebuild')
-rw-r--r--net-misc/openssh/openssh-4.0_p1-r2.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/net-misc/openssh/openssh-4.0_p1-r2.ebuild b/net-misc/openssh/openssh-4.0_p1-r2.ebuild
index cfa9db5d4189..71cfc0b28acc 100644
--- a/net-misc/openssh/openssh-4.0_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-4.0_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.0_p1-r2.ebuild,v 1.7 2005/09/08 23:54:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.0_p1-r2.ebuild,v 1.8 2005/10/19 03:32:26 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -49,28 +49,32 @@ src_unpack() {
unpack ${PARCH}.tar.gz
cd "${S}"
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-3.9_p1-configure-openct.patch #78730
epatch "${FILESDIR}"/openssh-3.9_p1-kerberos-detection.patch #80811
- use X509 && epatch ${DISTDIR}/${X509_PATCH}
- use sftplogging && epatch ${FILESDIR}/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
- use skey && epatch ${FILESDIR}/openssh-3.9_p1-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/openssh-3.9_p1-chroot.patch
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use smartcard && epatch ${FILESDIR}/openssh-3.9_p1-opensc.patch.bz2
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH}
+ use sftplogging && epatch "${FILESDIR}"/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
+ use skey && epatch "${FILESDIR}"/openssh-3.9_p1-skey.patch.bz2
+ use chroot && epatch "${FILESDIR}"/openssh-3.9_p1-chroot.patch
+ use selinux && epatch "${FILESDIR}"/${SELINUX_PATCH}.bz2
+ use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch.bz2
if ! use X509 ; then
- use smartcard && epatch ${DISTDIR}/${SECURID_PATCH} ${FILESDIR}/openssh-securid-1.3.1-updates.patch
- use smartcard && use ldap && epatch ${FILESDIR}/openssh-4.0_p1-smartcard-ldap-happy.patch
+ use smartcard && epatch "${DISTDIR}"/${SECURID_PATCH} "${FILESDIR}"/openssh-securid-1.3.1-updates.patch
+ use smartcard && use ldap && epatch "${FILESDIR}"/openssh-4.0_p1-smartcard-ldap-happy.patch
if use sftplogging ; then
ewarn "Sorry, sftplogging and ldap don't get along"
else
- use ldap && epatch ${DISTDIR}/${LDAP_PATCH}
+ use ldap && epatch "${DISTDIR}"/${LDAP_PATCH}
fi
elif use smartcard || use ldap ; then
ewarn "Sorry, x509 and smartcard/ldap don't get along"
fi
- use hpn && epatch ${DISTDIR}/${HPN_PATCH}
+ use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
sed -i '/LD.*ssh-keysign/s:$: -Wl,-z,now:' Makefile.in || die "setuid"