summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 04:02:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 04:02:36 +0000
commit493a1dd748abda399817d370a3a72c9adde727fd (patch)
tree2ebf0ac8d125a4bd4ea96ec6fd6b4a2fa953c3f3 /net-misc/iputils
parentAdd support to ipg for newer kernels #71756 by Christoph M. (diff)
downloadhistorical-493a1dd748abda399817d370a3a72c9adde727fd.tar.gz
historical-493a1dd748abda399817d370a3a72c9adde727fd.tar.bz2
historical-493a1dd748abda399817d370a3a72c9adde727fd.zip
patch shuffle
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/Manifest11
-rw-r--r--net-misc/iputils/files/021109-syserror.patch9
-rw-r--r--net-misc/iputils/files/021109-uclibc-no-ether_ntohost.patch (renamed from net-misc/iputils/files/iputils-20020927-no-ether_ntohost.patch)0
-rw-r--r--net-misc/iputils/iputils-021109-r3.ebuild7
4 files changed, 18 insertions, 9 deletions
diff --git a/net-misc/iputils/Manifest b/net-misc/iputils/Manifest
index 16dd33c41665..a8b54390b43e 100644
--- a/net-misc/iputils/Manifest
+++ b/net-misc/iputils/Manifest
@@ -2,19 +2,20 @@
Hash: SHA1
MD5 e2ccbeed9ec09bab7f076ddf927b1eee ChangeLog 5062
-MD5 73b9d1d0fbd243c19f6ab07fb3c78e5e iputils-021109-r3.ebuild 2745
+MD5 803f089c3d1999303ca7b3c72777c755 iputils-021109-r3.ebuild 2689
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 d85216426f34d4e768ab8f9f48c66e4f files/021109-syserror.patch 324
MD5 0a62fdeb93c761e5407fd3e185308a99 files/iputils-021109-pfkey.patch 3477
MD5 c11c8762616b29e6d556a147aaa9374a files/021109-no-pfkey-search.patch 307
MD5 2baac2d4f1c8f01957aaaf6b6349c203 files/021109-gcc34.patch 347
MD5 66a524e27160410a2dbaef8d2eed5365 files/digest-iputils-021109-r3 73
-MD5 b4615612d4514f12b35fbaf27d3e04fe files/iputils-20020927-no-ether_ntohost.patch 635
MD5 79de65b9da536090d0560ba51520fd9d files/iputils-021109-linux-udp-header.patch 418
MD5 c9986b4299c200260da8f025c5e4b0ea files/021109-ipg-linux-2.6.patch 981
+MD5 b4615612d4514f12b35fbaf27d3e04fe files/021109-uclibc-no-ether_ntohost.patch 635
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFB2hMCroRuSHgZdywRAhQ2AKCRIC75RG7rORc0gnrFxcDikPSPdACfbA5L
-GO5EnD1VXVnmFQOv0wMff1g=
-=5IT7
+iD8DBQFB2hVvroRuSHgZdywRAu7lAJ9n0Yp2L3OlxJRyq5poIMpHHh3FTQCffw6e
+H6nU75qDqX4NwB0WFbAIdO0=
+=i3u3
-----END PGP SIGNATURE-----
diff --git a/net-misc/iputils/files/021109-syserror.patch b/net-misc/iputils/files/021109-syserror.patch
new file mode 100644
index 000000000000..a4f94f409e38
--- /dev/null
+++ b/net-misc/iputils/files/021109-syserror.patch
@@ -0,0 +1,9 @@
+--- iputils/rdisc.c.orig 2005-01-03 22:53:27.852431840 -0500
++++ iputils/rdisc.c 2005-01-03 22:53:27.864430016 -0500
+@@ -1504,5 +1504,5 @@
+ if (logging)
+ syslog(LOG_ERR, "%s: %m", str);
+ else
+- (void) fprintf(stderr, "%s: %s\n", str, sys_errlist[errno]);
++ (void) fprintf(stderr, "%s: %s\n", str, strerror(errno));
+ }
diff --git a/net-misc/iputils/files/iputils-20020927-no-ether_ntohost.patch b/net-misc/iputils/files/021109-uclibc-no-ether_ntohost.patch
index e790d2b51038..e790d2b51038 100644
--- a/net-misc/iputils/files/iputils-20020927-no-ether_ntohost.patch
+++ b/net-misc/iputils/files/021109-uclibc-no-ether_ntohost.patch
diff --git a/net-misc/iputils/iputils-021109-r3.ebuild b/net-misc/iputils/iputils-021109-r3.ebuild
index adbf10c124f5..9142a744f783 100644
--- a/net-misc/iputils/iputils-021109-r3.ebuild
+++ b/net-misc/iputils/iputils-021109-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.14 2005/01/04 03:52:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.15 2005/01/04 04:02:36 vapier Exp $
inherit flag-o-matic gnuconfig eutils toolchain-funcs
@@ -39,6 +39,8 @@ src_unpack() {
epatch ${FILESDIR}/${PV}-gcc34.patch
epatch ${FILESDIR}/${PV}-no-pfkey-search.patch
epatch ${FILESDIR}/${PV}-ipg-linux-2.6.patch #71756
+ epatch ${FILESDIR}/${PV}-syserror.patch
+ epatch ${FILESDIR}/${PV}-uclibc-no-ether_ntohost.patch
# make iputils work with newer glibc snapshots
epatch ${FILESDIR}/${P}-linux-udp-header.patch
@@ -57,9 +59,6 @@ src_unpack() {
sed -i "s:-ll:-lfl -L${ROOT}/usr/lib ${LDFLAGS}:" setkey/Makefile || die "sed setkey failed"
sed -i 's:yacc:bison -y:' libipsec/Makefile #59191
-
- use uclibc && sed -e 's/sys_errlist\[errno\]/strerror(errno)/' -i ${S}/rdisc.c
- use uclibc && epatch ${FILESDIR}/${PN}-20020927-no-ether_ntohost.patch
}
src_compile() {