summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-01-01 00:56:46 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-01-01 00:56:46 +0000
commitbf6c75d4b8bd13bcc382940e17d65262c00833ec (patch)
treef028024b0b54f72d101ed230806772c107556e80 /net-misc/htbinit/htbinit-0.8.5-r4.ebuild
parentFix py-compile idiom for automake-1.11.2 compatibility (bug #396585). (diff)
downloadhistorical-bf6c75d4b8bd13bcc382940e17d65262c00833ec.tar.gz
historical-bf6c75d4b8bd13bcc382940e17d65262c00833ec.tar.bz2
historical-bf6c75d4b8bd13bcc382940e17d65262c00833ec.zip
Revbump. Don't use the deprecated $opts variable, bug 386767.
Package-Manager: portage-2.1.10.41/cvs/Linux i686 RepoMan-Options: --force
Diffstat (limited to 'net-misc/htbinit/htbinit-0.8.5-r4.ebuild')
-rw-r--r--net-misc/htbinit/htbinit-0.8.5-r4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/htbinit/htbinit-0.8.5-r4.ebuild b/net-misc/htbinit/htbinit-0.8.5-r4.ebuild
new file mode 100644
index 000000000000..d48cab715935
--- /dev/null
+++ b/net-misc/htbinit/htbinit-0.8.5-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/htbinit-0.8.5-r4.ebuild,v 1.1 2012/01/01 00:56:46 idl0r Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="Sets up Hierachical Token Bucket based traffic control (QoS) with iproute2"
+HOMEPAGE="http://www.sourceforge.net/projects/htbinit"
+SRC_URI="mirror://sourceforge/htbinit/htb.init-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~ppc ~sparc x86"
+IUSE="ipv6 esfq"
+
+DEPEND="sys-apps/iproute2"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ for i in NET_SCH_HTB NET_SCH_SFQ NET_CLS_FW NET_CLS_U32 NET_CLS_ROUTE ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='module needed at runtime!'"
+ done
+ use esfq && CONFIG_CHECK="${CONFIG_CHECK} ~NET_SCH_ESFQ"
+ WARNING_NET_SCH_ESFQ='module needed at runtime! Available at http://fatooh.org/esfq-2.6/'
+ export CONFIG_CHECK
+ linux-info_pkg_setup
+}
+
+src_unpack() {
+ cp "${DISTDIR}"/htb.init-v${PV} "${S}"/htb.init
+}
+
+src_compile() {
+ sed -i 's|/etc/sysconfig/htb|/etc/htb|g' "${S}"/htb.init
+ epatch "${FILESDIR}"/htb.init-v0.8.5_tos.patch
+ use ipv6 && epatch "${FILESDIR}"/htb_0.8.5_ipv6.diff
+ use esfq && epatch "${FILESDIR}"/htb_0.8.5_esfq.diff
+ epatch "${FILESDIR}"/prio_rule.patch
+ epatch "${FILESDIR}"/timecheck_fix.patch
+ epatch "${FILESDIR}"/htb.init_find_fix.patch
+}
+
+src_install() {
+ dosbin htb.init
+
+ newinitd "${FILESDIR}"/htbinit.rc htbinit
+
+ keepdir /etc/htb
+}
+
+pkg_postinst() {
+ einfo 'Run "rc-update add htbinit default" to run htb.init at startup.'
+ einfo 'Please, read carefully the htb.init documentation.'
+ einfo 'new directory to store configuration /etc/htb'
+}