summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-11-25 15:33:42 +0000
committerMarinus Schraal <foser@gentoo.org>2003-11-25 15:33:42 +0000
commit95cb4fee3650b9cc70d0f78edf4c3e9c39158d70 (patch)
treede9f1256265a4e466001dd48ed795e167cfa2614 /net-mail
parentAdded a sed line to resolve getline re-definition problem (bug 32968) (diff)
downloadhistorical-95cb4fee3650b9cc70d0f78edf4c3e9c39158d70.tar.gz
historical-95cb4fee3650b9cc70d0f78edf4c3e9c39158d70.tar.bz2
historical-95cb4fee3650b9cc70d0f78edf4c3e9c39158d70.zip
fix use switching
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/balsa/ChangeLog7
-rw-r--r--net-mail/balsa/Manifest3
-rw-r--r--net-mail/balsa/balsa-2.0.15-r1.ebuild56
3 files changed, 64 insertions, 2 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index d8df9f5ae2c9..dd45c3a58be7 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/balsa
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.44 2003/11/10 15:52:30 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.45 2003/11/25 15:33:41 foser Exp $
+
+*balsa-2.0.15-r1 (25 Nov 2003)
+
+ 25 Nov 2003; foser <foser@gentoo.org> balsa-2.0.15-r1.ebuild :
+ Yay, fix configure switching.. move it to the right spot (duh!)
*balsa-2.0.15 (10 Nov 2003)
diff --git a/net-mail/balsa/Manifest b/net-mail/balsa/Manifest
index 85decfa0736c..fcd83005b9d3 100644
--- a/net-mail/balsa/Manifest
+++ b/net-mail/balsa/Manifest
@@ -1,6 +1,6 @@
MD5 39bc6b56e6ea2b4a4acdf5a232121663 balsa-2.0.14.ebuild 1726
MD5 694d66321b4ec7cced8adfcdc2f8b080 balsa-2.0.11.ebuild 1648
-MD5 b9c2e217eb00175d69b12f1b2ca0a408 balsa-2.0.15.ebuild 1451
+MD5 49b7970e97b0cac087137faefbc160e5 balsa-2.0.15-r1.ebuild 1441
MD5 a679efb198ad87b68ac094b4d27716c3 balsa-2.0.10.ebuild 1722
MD5 306baf1b7cdbf5f70da066752ebd44af balsa-1.4.3.ebuild 1715
MD5 8e9d2fd32f66fd9537a6f7b4f3ab83b7 ChangeLog 7573
@@ -11,3 +11,4 @@ MD5 2011fe7cfdc0ef2d21825be38169169f files/digest-balsa-2.0.14 66
MD5 aa4090173ee51cb5766ef1b3a6d6f379 files/digest-balsa-2.0.15 66
MD5 7640c6a66bb87af1486164581e95296d files/balsa-1.4.0-gentoo.diff 830
MD5 92455a1d3e62f5727b37d43f60acdf12 files/digest-balsa-1.4.3 65
+MD5 aa4090173ee51cb5766ef1b3a6d6f379 files/digest-balsa-2.0.15-r1 66
diff --git a/net-mail/balsa/balsa-2.0.15-r1.ebuild b/net-mail/balsa/balsa-2.0.15-r1.ebuild
new file mode 100644
index 000000000000..a729c70f3d1a
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.15-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.15-r1.ebuild,v 1.1 2003/11/25 15:33:42 foser Exp $
+
+inherit gnome2 eutils
+
+IUSE="ssl gtkhtml perl ldap crypt"
+DESCRIPTION="Email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND="net-mail/mailbase
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.1.4
+ >=gnome-base/libgnomeprintui-2.1.4
+ >=net-libs/libesmtp-0.8.11
+ virtual/aspell-dict
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( =gnome-extra/libgtkhtml-2* )
+ ldap? ( net-nds/openldap )
+ crypt? ( =app-crypt/gpgme-0.3.14* )"
+
+DEPEND="dev-util/pkgconfig
+ >=app-text/scrollkeeper-0.1.4
+ ${RDEPEND}"
+
+src_compile() {
+ local myconf
+
+ libmutt/configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ # threads diabled because of 17079
+ econf \
+ `use_with ssl` \
+ `use_enable gtkhtml` \
+ `use_enable perl pcre` \
+ `use_enable ldap` \
+ `use_with crypt gpgme` \
+ --disable-threads || die "configure balsa failed"
+
+ emake || die "emake failed"
+}
+
+DOCS="AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO docs/*"