summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 03:44:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 03:44:23 +0000
commit8c9b512cd291597c70815d59ac4b4cf05c2538ec (patch)
treec54a5f5fef042f5c80b5412da3ad0954e42264c0 /net-mail
parentversion bump (diff)
downloadhistorical-8c9b512cd291597c70815d59ac4b4cf05c2538ec.tar.gz
historical-8c9b512cd291597c70815d59ac4b4cf05c2538ec.tar.bz2
historical-8c9b512cd291597c70815d59ac4b4cf05c2538ec.zip
$DEBUGBUILD -> use debug
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tpop3d/tpop3d-1.4.2.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-mail/tpop3d/tpop3d-1.4.2.ebuild b/net-mail/tpop3d/tpop3d-1.4.2.ebuild
index 287fbfe29aaa..d38ab6440c3b 100644
--- a/net-mail/tpop3d/tpop3d-1.4.2.ebuild
+++ b/net-mail/tpop3d/tpop3d-1.4.2.ebuild
@@ -1,20 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.4.2.ebuild,v 1.5 2003/06/12 21:33:32 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.4.2.ebuild,v 1.6 2003/08/03 03:44:23 vapier Exp $
-inherit eutils
-
-IUSE="ssl ldap mysql perl pam tcpd maildir"
-
-S=${WORKDIR}/${P}
DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support."
+HOMEPAGE="http://www.ex-parrot.com/~chris/tpop3d/"
SRC_URI="http://www.ex-parrot.com/~chris/tpop3d/${P}.tar.gz
http://www.ex-parrot.com/~chris/tpop3d/${P}-auth-flatfile-broken.patch"
-HOMEPAGE="http://www.ex-parrot.com/~chris/tpop3d/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="ssl ldap mysql perl pam tcpd maildir debug"
DEPEND="virtual/glibc
ssl? ( >=dev-libs/openssl-0.9.6 )
@@ -27,7 +23,7 @@ DEPEND="virtual/glibc
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
- epatch ${DISTDIR}/${P}-auth-flatfile-broken.patch || die
+ epatch ${DISTDIR}/${P}-auth-flatfile-broken.patch
}
src_compile() {
@@ -63,7 +59,7 @@ src_compile() {
if [ ! -a $ENABLE_DRAC ]; then
myconf="${myconf} --enable-drac"
fi
- if [ ! -z $DEBUGBUILD ]; then
+ if [ `use debug` ]; then
myconf="${myconf} --enable-electric-fence --enable-backtrace"
fi
econf ${myconf} || die "./configure failed"
@@ -71,10 +67,11 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodir /etc/tpop3d
}
+
pkg_postinst() {
einfo "Read the tpop3d.conf manpage"
einfo "Please create /etc/tpop3d/tpop3d.conf to fit your Configuration"