summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-09-19 12:50:49 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-09-19 12:50:49 +0000
commit4e459d4d2026e33fe0fb5767844b5845db584cd8 (patch)
treec5ada740c1420df152c1765cc396d3a8e9fa4c3a /net-mail
parentVersion bump (diff)
downloadhistorical-4e459d4d2026e33fe0fb5767844b5845db584cd8.tar.gz
historical-4e459d4d2026e33fe0fb5767844b5845db584cd8.tar.bz2
historical-4e459d4d2026e33fe0fb5767844b5845db584cd8.zip
Version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/ssmtp/Manifest4
-rw-r--r--net-mail/ssmtp/files/digest-ssmtp-2.60.41
-rw-r--r--net-mail/ssmtp/ssmtp-2.60.4.ebuild83
3 files changed, 86 insertions, 2 deletions
diff --git a/net-mail/ssmtp/Manifest b/net-mail/ssmtp/Manifest
index 5589a9d7beaa..176addd424c6 100644
--- a/net-mail/ssmtp/Manifest
+++ b/net-mail/ssmtp/Manifest
@@ -1,9 +1,9 @@
-MD5 4162dff5d625b568b2257214423cfe7f ChangeLog 2592
+MD5 51fc9e143cc72ee94c7b54f83be3814f ChangeLog 2703
MD5 9d260a5e3ba800b7fe887088118a3a2f ssmtp-2.38.14-r1.ebuild 1489
MD5 a49ccfcccd8e1546ebd0e54b71ec2e19 ssmtp-2.48.ebuild 1570
MD5 fabd9d99bc1f05a1e89649ffe387e98d ssmtp-2.60.3.ebuild 2205
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 faa88c947120c6f0573590e9a5740c74 ssmtp-2.60.4.ebuild 2189
+MD5 de405c7f40c3016f4dbf279dd01c8ae9 ssmtp-2.60.4.ebuild 2188
MD5 0c220581f9fe43f95d74864b63cf5121 files/digest-ssmtp-2.38.14-r1 64
MD5 7acea6571783e2e8d40bb7aafad39d21 files/digest-ssmtp-2.48 62
MD5 fdf4a04b5fc0cec5d1e9b0cf355d0567 files/digest-ssmtp-2.60.3 64
diff --git a/net-mail/ssmtp/files/digest-ssmtp-2.60.4 b/net-mail/ssmtp/files/digest-ssmtp-2.60.4
new file mode 100644
index 000000000000..5a7840ef2d23
--- /dev/null
+++ b/net-mail/ssmtp/files/digest-ssmtp-2.60.4
@@ -0,0 +1 @@
+MD5 88fff70f14a001e09b713aa6326162cf ssmtp_2.60.4.tar.gz 160073
diff --git a/net-mail/ssmtp/ssmtp-2.60.4.ebuild b/net-mail/ssmtp/ssmtp-2.60.4.ebuild
new file mode 100644
index 000000000000..534000edeae1
--- /dev/null
+++ b/net-mail/ssmtp/ssmtp-2.60.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ssmtp/ssmtp-2.60.4.ebuild,v 1.1 2003/09/19 12:50:44 aliz Exp $
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/${P/-/_}.tar.gz"
+HOMEPAGE="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~amd64 ~ia64"
+LICENSE="GPL-2"
+IUSE="ssl ipv6 md5sum"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+RDEPEND="!virtual/mta
+ net-mail/mailbase
+ ssl? ( dev-libs/openssl )"
+PROVIDE="virtual/mta"
+
+S=${WORKDIR}/ssmtp-2.60
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ use ssl && epatch ${FILESDIR}/starttls.diff
+}
+
+src_compile() {
+ local myconf
+
+ myconf="$( use_enable ssl ) \
+ $( use_enable ipv6 inet6 ) \
+ $( use_enable md5sum md5suth )"
+
+ econf \
+ --sysconfdir=/etc/ssmtp \
+ ${myconf} || die
+
+ make clean || die
+ make etcdir=/etc || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosbin ssmtp
+ chmod 755 ${D}/usr/sbin/ssmtp
+ dosym /usr/sbin/ssmtp /usr/bin/mailq
+ dosym /usr/sbin/ssmtp /usr/bin/newaliases
+ # Removed symlink due to conflict with mailx
+ # See bug #7448
+ #dosym /usr/sbin/ssmtp /usr/bin/mail
+ dosym /usr/sbin/ssmtp /usr/sbin/sendmail
+ dosym /usr/sbin/ssmtp /usr/lib/sendmail
+ doman ssmtp.8
+ dosym /usr/share/man/man8/ssmtp.8 /usr/share/man/man8/sendmail.8
+ dodoc INSTALL README TLS
+ newdoc ssmtp-2.60.lsm
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+
+ # Set up config file
+ # See bug #22658
+ #local conffile="/etc/ssmtp/ssmtp.conf"
+ #local hostname=`hostname -f`
+ #local domainname=`hostname -d`
+ #mv ${conffile} ${conffile}.orig
+ #sed -e "s:rewriteDomain=:rewriteDomain=${domainname}:g" \
+ # -e "s:_HOSTNAME_:${hostname}:" \
+ # -e "s:^mailhub=mail:mailhub=mail.${domainname}:g" \
+ # ${conffile}.orig > ${conffile}.pre
+ #if [ `use ssl` ];
+ #then
+ # sed -e "s:^#UseTLS=YES:UseTLS=YES:g" \
+ # ${conffile}.pre > ${conffile}
+ # mv ${conffile}.pre ${conffile}.orig
+ #else
+ # mv ${conffile}.pre ${conffile}
+ #fi
+}
+
+
+