summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-16 19:16:06 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-16 19:16:06 +0000
commit044706df4c867caed00b1ba1752e193c39db4c3d (patch)
tree51ee06e3009786dd4c5c92767d27e83933f81663 /net-mail/fetchmail
parentremoved windowmaker dependancy. (diff)
downloadhistorical-044706df4c867caed00b1ba1752e193c39db4c3d.tar.gz
historical-044706df4c867caed00b1ba1752e193c39db4c3d.tar.bz2
historical-044706df4c867caed00b1ba1752e193c39db4c3d.zip
Version bump.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog8
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.1.ebuild79
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.11
3 files changed, 87 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 0785d3fbbe3c..1660b638002b 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.20 2002/12/28 21:11:22 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.21 2003/01/16 19:16:06 raker Exp $
+
+*fetchmail-6.2.1 (16 Jan 2003)
+
+ 16 Jan 2003; Nick Hadaway <raker@gentoo.org> fetchmail-6.2.1.ebuild,
+ files/digest-fetchmail-6.2.1 :
+ Version bump.
*fetchmail-6.2.0-r1 (26 Dec 2002)
diff --git a/net-mail/fetchmail/fetchmail-6.2.1.ebuild b/net-mail/fetchmail/fetchmail-6.2.1.ebuild
new file mode 100644
index 000000000000..484a46a84f88
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.1.ebuild,v 1.1 2003/01/16 19:16:06 raker Exp $
+
+IUSE="ssl nls"
+S="${WORKDIR}/${P}"
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="x86 ~alpha"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fetchmail-6.2.0-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use ipv6 && myconf="${myconf} --enable-inet6" \
+ || myconf="${myconf} --disable-inet6"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.1 b/net-mail/fetchmail/files/digest-fetchmail-6.2.1
new file mode 100644
index 000000000000..8d67be225e13
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.1
@@ -0,0 +1 @@
+MD5 8f9f8f809caf03e064b42361ae5756d2 fetchmail-6.2.1.tar.gz 1139251