summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-07 19:02:45 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-07 19:02:45 +0000
commit0309bbeeced25bcfa3cff0fc3b3b5f8459bcdeb3 (patch)
tree0a890d7e05cc684d7d2a927b22b8510282150d30 /net-mail/balsa
parentFix all the prelink emerge errors (diff)
downloadhistorical-0309bbeeced25bcfa3cff0fc3b3b5f8459bcdeb3.tar.gz
historical-0309bbeeced25bcfa3cff0fc3b3b5f8459bcdeb3.tar.bz2
historical-0309bbeeced25bcfa3cff0fc3b3b5f8459bcdeb3.zip
New version
Diffstat (limited to 'net-mail/balsa')
-rw-r--r--net-mail/balsa/ChangeLog7
-rw-r--r--net-mail/balsa/balsa-2.0.3.ebuild4
-rw-r--r--net-mail/balsa/balsa-2.0.5.ebuild76
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.51
4 files changed, 85 insertions, 3 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index b4f9decc2f61..3c5422ab65d5 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/balsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.26 2002/12/20 03:48:29 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.27 2003/01/07 19:02:45 foser Exp $
+
+*balsa-2.0.5 (07 Jan 2003)
+
+ 07 Jan 2003; foser <foser@gentoo.org> balsa-2.0.5.ebuild :
+ New version, spell should be aspell ready now
19 Dec 2002; Dean Bailey <alron@gentoo.org> :
Removed sparc64 keyword
diff --git a/net-mail/balsa/balsa-2.0.3.ebuild b/net-mail/balsa/balsa-2.0.3.ebuild
index cfa1643cb2bd..42ec8e1a1e1c 100644
--- a/net-mail/balsa/balsa-2.0.3.ebuild
+++ b/net-mail/balsa/balsa-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.3.ebuild,v 1.2 2002/12/20 03:48:29 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.3.ebuild,v 1.3 2003/01/07 19:02:45 foser Exp $
inherit debug gnome2 eutils
@@ -12,7 +12,7 @@ HOMEPAGE="http://balsa.gnome.org"
SLOT="2"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc"
RDEPEND="net-mail/mailbase
>=dev-libs/glib-2
diff --git a/net-mail/balsa/balsa-2.0.5.ebuild b/net-mail/balsa/balsa-2.0.5.ebuild
new file mode 100644
index 000000000000..18a931918ffd
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.5.ebuild,v 1.1 2003/01/07 19:02:45 foser Exp $
+
+inherit gnome2 eutils
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+RDEPEND="net-mail/mailbase
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=net-libs/libesmtp-0.8.11
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ =gnome-base/libgnomeprint-1*
+ =gnome-base/libgnomeprintui-1*
+ spell? ( >=app-text/aspell-0.50 )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( >=gnome-extra/libgtkhtml-2 )
+ ldap? ( net-nds/openldap )"
+
+DEPEND="dev-util/pkgconfig
+ >=app-text/scrollkeeper-0.1.4
+ ${RDEPEND}"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ use gtkhtml \
+ && myconf="${myconf} --with-gtkhtml" \
+ || myconf="${myconf} --without-gtkhtml"
+ use perl \
+ && myconf="${myconf} --enable-pcre" \
+ || myconf="${myconf} --disable-pcre"
+
+ use spell \
+ && myconf="${myconf} --with-aspell" \
+ || myconf="${myconf} --without-aspell --without-spell"
+
+ libmutt/configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ myconf="${myconf} --enable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/files/digest-balsa-2.0.5 b/net-mail/balsa/files/digest-balsa-2.0.5
new file mode 100644
index 000000000000..1cc227168314
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.5
@@ -0,0 +1 @@
+MD5 4a8ab1c6733133b38ae0ff3fa53a3361 balsa-2.0.5.tar.bz2 2397320