summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-09-26 19:55:27 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-09-26 19:55:27 +0000
commit3e71c0edc1999f489a835a06b2e403562e704156 (patch)
treece987f45a593ed7bee112db7972feceeb08da247 /net-libs
parentAdded mailx, generally used in scripts (diff)
downloadhistorical-3e71c0edc1999f489a835a06b2e403562e704156.tar.gz
historical-3e71c0edc1999f489a835a06b2e403562e704156.tar.bz2
historical-3e71c0edc1999f489a835a06b2e403562e704156.zip
Added liblockfile, used by mailx to lock mailboxes
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liblockfile/files/digest-liblockfile-1.031
-rw-r--r--net-libs/liblockfile/liblockfile-1.03.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/liblockfile/files/digest-liblockfile-1.03 b/net-libs/liblockfile/files/digest-liblockfile-1.03
new file mode 100644
index 000000000000..da1f29591fa6
--- /dev/null
+++ b/net-libs/liblockfile/files/digest-liblockfile-1.03
@@ -0,0 +1 @@
+MD5 a3700a6c958d60e070849231ef14136d liblockfile_1.03.tar.gz
diff --git a/net-libs/liblockfile/liblockfile-1.03.ebuild b/net-libs/liblockfile/liblockfile-1.03.ebuild
new file mode 100644
index 000000000000..cce30e0e9bba
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.03.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Martin Schlemmer <azarah@saintmail.net>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Implements functions designed to lock the standard mailboxes."
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/libl/liblockfile/liblockfile_1.03.tar.gz"
+HOMEPAGE="http://www.debian.org"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ ./configure --with-mailgroup=mail --prefix=/usr --mandir=/usr/share/man
+ make || die
+
+}
+
+src_install () {
+
+ dodir /usr/bin /usr/include /usr/lib /usr/share/man/man1 /usr/share/man/man3
+ make ROOT=${D} install || die
+
+}
+