summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-10-03 20:33:24 +0000
committerMarinus Schraal <foser@gentoo.org>2003-10-03 20:33:24 +0000
commit28f563901b127f7eb85381660d3b2dec4f4e3ec2 (patch)
treefad9d9702aa54fba159852cf0f99e7dc8b5f8fe0 /net-libs
parentMark stable x86 (diff)
downloadhistorical-28f563901b127f7eb85381660d3b2dec4f4e3ec2.tar.gz
historical-28f563901b127f7eb85381660d3b2dec4f4e3ec2.tar.bz2
historical-28f563901b127f7eb85381660d3b2dec4f4e3ec2.zip
add patch
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/loudmouth/ChangeLog3
-rw-r--r--net-libs/loudmouth/Manifest5
-rw-r--r--net-libs/loudmouth/files/loudmouth-0.14-gnutls_null_no_error.patch14
-rw-r--r--net-libs/loudmouth/loudmouth-0.14.ebuild10
4 files changed, 28 insertions, 4 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 174746adaaba..48714f5b41ee 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for net-libs/loudmouth
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.8 2003/10/03 17:11:15 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.9 2003/10/03 20:33:19 foser Exp $
*loudmouth-0.14 (03 Oct 2003)
03 Oct 2003; foser <foser@gentoo.org> loudmouth-0.14.ebuild :
New version
+ Added patch to fix possible gnutls problems
*loudmouth-0.13.2-r1 (07 Sep 2003)
diff --git a/net-libs/loudmouth/Manifest b/net-libs/loudmouth/Manifest
index ac88c721ef8b..746b134d8913 100644
--- a/net-libs/loudmouth/Manifest
+++ b/net-libs/loudmouth/Manifest
@@ -1,8 +1,9 @@
-MD5 0b6b796398107c9a14d7d78c6cef17c2 loudmouth-0.14.ebuild 673
+MD5 c60d8f2dfc2fc25a810e24a24da75c5b loudmouth-0.14.ebuild 759
MD5 b74727a298acb1963a76933d1d34b3fb loudmouth-0.13.2.ebuild 697
MD5 ed85cf2047a3736ad50398f159953198 loudmouth-0.13.2-r1.ebuild 678
-MD5 a5f9a7934062f8c15e6da7518cff2911 ChangeLog 1082
+MD5 f6a84b457ce19b9d3bb159d8621831e5 ChangeLog 1128
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 958ddf5515459bebdf9f95fa84341b15 files/loudmouth-0.14-gnutls_null_no_error.patch 538
MD5 5847cfbe6c3d2f88d2d4d38cbc3fbae2 files/digest-loudmouth-0.13.2 69
MD5 5847cfbe6c3d2f88d2d4d38cbc3fbae2 files/digest-loudmouth-0.13.2-r1 69
MD5 2b2cb9ffc60620b4f2874941b96f177a files/digest-loudmouth-0.14 67
diff --git a/net-libs/loudmouth/files/loudmouth-0.14-gnutls_null_no_error.patch b/net-libs/loudmouth/files/loudmouth-0.14-gnutls_null_no_error.patch
new file mode 100644
index 000000000000..30f0eeedfb56
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-0.14-gnutls_null_no_error.patch
@@ -0,0 +1,14 @@
+--- loudmouth-0.14/loudmouth/lm-connection.c 2003-10-02 10:36:30.000000000 +0200
++++ loudmouth-0.14/loudmouth/lm-connection.c.new 2003-10-03 21:42:05.000000000 +0200
+@@ -437,7 +437,10 @@
+ if (connection->use_ssl) {
+ bytes_read = gnutls_record_recv (connection->gnutls_session,
+ buf,IN_BUFFER_SIZE - 1);
+- if (bytes_read <= 0) {
++ if (bytes_read == GNUTLS_E_AGAIN) {
++ status = G_IO_STATUS_AGAIN;
++ }
++ else if (bytes_read <= 0) {
+ status = G_IO_STATUS_ERROR;
+
+ //connection_error_event (connection->io_channel,
diff --git a/net-libs/loudmouth/loudmouth-0.14.ebuild b/net-libs/loudmouth/loudmouth-0.14.ebuild
index 249a5093cbf3..b31756c07088 100644
--- a/net-libs/loudmouth/loudmouth-0.14.ebuild
+++ b/net-libs/loudmouth/loudmouth-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-0.14.ebuild,v 1.1 2003/10/03 17:11:15 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-0.14.ebuild,v 1.2 2003/10/03 20:33:19 foser Exp $
inherit gnome2
@@ -26,3 +26,11 @@ use ssl \
&& G2CONF="${G2CONF} --with-ssl" \
|| G2CONF="${G2CONF} --without-ssl"
+src_unpack() {
+
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-gnutls_null_no_error.patch
+
+}
+