summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-05-15 12:05:07 +0000
committerUlrich Müller <ulm@gentoo.org>2014-05-15 12:05:07 +0000
commitddd96183e7bae3c8499804fa8d2f4c2bc7ad4931 (patch)
tree1c998796ea88a662551079209453489746c9f463 /net-libs/ptlib/ptlib-2.12.4.ebuild
parentTake maintainership of package (diff)
downloadhistorical-ddd96183e7bae3c8499804fa8d2f4c2bc7ad4931.tar.gz
historical-ddd96183e7bae3c8499804fa8d2f4c2bc7ad4931.tar.bz2
historical-ddd96183e7bae3c8499804fa8d2f4c2bc7ad4931.zip
QA: Rename "audio" USE flag to "sound", bug 357661.
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x9433907D693FB5B8!
Diffstat (limited to 'net-libs/ptlib/ptlib-2.12.4.ebuild')
-rw-r--r--net-libs/ptlib/ptlib-2.12.4.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-libs/ptlib/ptlib-2.12.4.ebuild b/net-libs/ptlib/ptlib-2.12.4.ebuild
index bf62542fafa2..5ff9443bc1d6 100644
--- a/net-libs/ptlib/ptlib-2.12.4.ebuild
+++ b/net-libs/ptlib/ptlib-2.12.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.4.ebuild,v 1.2 2013/06/24 09:57:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.4.ebuild,v 1.3 2014/05/15 12:04:06 ulm Exp $
EAPI=5
@@ -15,19 +15,19 @@ LICENSE="MPL-1.0"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio remote sasl sdl serial
-shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+shmvideo snmp soap socks +sound ssl static-libs +stun telnet tts v4l +video
vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
lua? ( dev-lang/lua )
odbc? ( dev-db/unixODBC )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -78,8 +78,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf+=" --disable-plugins"
else
myconf+=" --enable-plugins"
@@ -110,7 +110,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -141,6 +140,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -182,7 +182,7 @@ src_install() {
dodoc History.txt ReadMe.txt ReadMe_QOS.txt
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt
fi
@@ -210,8 +210,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi