summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-20 16:47:30 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-20 16:47:30 +0000
commitdd63438c162220b701afefb6784d85a8efc49c53 (patch)
tree65caddba35200b40ef235ed08efa076f5c893d91 /net-libs/openh323/openh323-1.9.3.ebuild
parentUpdated to latest version of pwlib to coincide with release of (diff)
downloadhistorical-dd63438c162220b701afefb6784d85a8efc49c53.tar.gz
historical-dd63438c162220b701afefb6784d85a8efc49c53.tar.bz2
historical-dd63438c162220b701afefb6784d85a8efc49c53.zip
Updated openh323 to coincide with the gnomemeeting-0.93.0 release.
Diffstat (limited to 'net-libs/openh323/openh323-1.9.3.ebuild')
-rw-r--r--net-libs/openh323/openh323-1.9.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/openh323/openh323-1.9.3.ebuild b/net-libs/openh323/openh323-1.9.3.ebuild
new file mode 100644
index 000000000000..86e723a601a8
--- /dev/null
+++ b/net-libs/openh323/openh323-1.9.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.9.3.ebuild,v 1.1 2002/07/20 16:47:30 raker Exp $
+
+S="${WORKDIR}/openh323"
+SRC_URI="http://www.openh323.org/bin/openh323_${PV}.tar.gz"
+HOMEPAGE="http://www.openh323.org"
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing
+protocol"
+
+DEPEND=">=dev-libs/pwlib-1.3.3"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="x86"
+
+src_compile() {
+ cd ${S}
+ export PWLIBDIR=/usr/share/pwlib
+ export OPENH323DIR=${S}
+ echo $PWLIBDIR
+ make optshared || die
+}
+
+src_install() {
+ mkdir -p ${D}/usr/lib
+ mkdir -p ${D}/usr/share/openh323
+ cd ${S}/lib
+ mv lib* ${D}/usr/lib
+ cd ${S}
+ cp -a * ${D}/usr/share/openh323
+ rm -rf ${D}/usr/share/openh323/make/CVS
+ rm -rf ${D}/usr/share/openh323/tools/CVS
+ rm -rf ${D}/usr/share/openh323/tools/asnparser/CVS
+ rm -rf ${D}/usr/share/openh323/src
+ rm -rf ${D}/usr/share/openh323/include/CVS
+ rm -rf ${D}/usr/share/openh323/include/ptlib/unix/CVS
+ rm -rf ${D}/usr/share/openh323/include/ptlib/CVS
+
+ cd ${D}/usr/lib
+ ln -sf libh323_linux_x86_r.so.${PV} libopenh323.so
+}
+
+