summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-23 17:32:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-23 17:32:49 +0000
commit084ef7d7225d5f932dd992b83062e033fa20c320 (patch)
tree00843bb5e500251e97bffd0fef488129c6ae5f0b /net-libs/libzapojit/libzapojit-0.0.2.ebuild
parentVersion bump for Gnome 3.6. Bump to EAPI=5 and fix licences. Drop old revisio... (diff)
downloadhistorical-084ef7d7225d5f932dd992b83062e033fa20c320.tar.gz
historical-084ef7d7225d5f932dd992b83062e033fa20c320.tar.bz2
historical-084ef7d7225d5f932dd992b83062e033fa20c320.zip
Initial ebuild from gnome overlay.
Package-Manager: portage-2.2.0_alpha149/cvs/Linux x86_64 Manifest-Sign-Key: 0xC6085806
Diffstat (limited to 'net-libs/libzapojit/libzapojit-0.0.2.ebuild')
-rw-r--r--net-libs/libzapojit/libzapojit-0.0.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libzapojit/libzapojit-0.0.2.ebuild b/net-libs/libzapojit/libzapojit-0.0.2.ebuild
new file mode 100644
index 000000000000..84fea1f31e0b
--- /dev/null
+++ b/net-libs/libzapojit/libzapojit-0.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libzapojit/libzapojit-0.0.2.ebuild,v 1.1 2012/12/23 17:32:45 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs"
+HOMEPAGE="http://git.gnome.org/browse/libzapojit"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/libsoup-2.38:2.4
+ dev-libs/json-glib
+ net-libs/rest
+ net-libs/gnome-online-accounts
+
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common:3
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --enable-compile-warnings=minimum
+ --disable-static
+ $(use_enable introspection)"
+ gnome2_src_configure
+}