summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-06-08 03:41:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-06-08 03:41:37 +0000
commit6df634e1b4a92ae015a3a419cbbc0f28f3e3603a (patch)
tree1310591517ca31705e04097779001339cc1d3549 /net-libs/c-client
parentinitial import (diff)
downloadhistorical-6df634e1b4a92ae015a3a419cbbc0f28f3e3603a.tar.gz
historical-6df634e1b4a92ae015a3a419cbbc0f28f3e3603a.tar.bz2
historical-6df634e1b4a92ae015a3a419cbbc0f28f3e3603a.zip
initial import
Diffstat (limited to 'net-libs/c-client')
-rw-r--r--net-libs/c-client/Manifest5
-rw-r--r--net-libs/c-client/c-client-2002d.ebuild74
-rw-r--r--net-libs/c-client/files/2002d-Makefile.patch65
-rw-r--r--net-libs/c-client/files/digest-c-client-2002d1
4 files changed, 143 insertions, 2 deletions
diff --git a/net-libs/c-client/Manifest b/net-libs/c-client/Manifest
index 5d18b32c5c24..b4301b484187 100644
--- a/net-libs/c-client/Manifest
+++ b/net-libs/c-client/Manifest
@@ -1,3 +1,4 @@
-MD5 6df9cd63bf3c9022ffa6078f342fe87e c-client-2002d.ebuild 1589
-MD5 261642cc8a2c80e33293bebbd8e9fa97 files/2002b-Makefile.patch 2203
+MD5 c491ec056799038d462c1117b9df16e1 ChangeLog 520
+MD5 4bbd575786eefe30845f77bac654d926 c-client-2002d.ebuild 1822
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d 62
+MD5 c8cf618ac210e06a1641871b30550e8f files/2002d-Makefile.patch 2174
diff --git a/net-libs/c-client/c-client-2002d.ebuild b/net-libs/c-client/c-client-2002d.ebuild
new file mode 100644
index 000000000000..31de61409e2b
--- /dev/null
+++ b/net-libs/c-client/c-client-2002d.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002d.ebuild,v 1.1 2003/06/08 03:41:35 robbat2 Exp $
+
+MY_PN=imap
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW IMAP c-client library"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc ~hppa ~alpha"
+IUSE="ssl"
+
+PROVIDE="virtual/imap-c-client"
+RDEPEND="ssl? ( dev-libs/openssl )
+ !virtual/imap-c-client"
+DEPEND="${RDEPEND}
+ >=sys-libs/pam-0.72"
+
+src_unpack() {
+ unpack ${A}
+
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ # Modifications so we can build it optimially and correctly
+ cd ${S}/src/osdep/unix/
+ cp Makefile Makefile.orig
+ sed \
+ -e 's,-g -fno-omit-frame-pointer -O6,${CFLAGS},g' \
+ -e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
+ -e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
+ < Makefile.orig > Makefile
+
+ # Apply a patch to only build the stuff we need for c-client
+ cd ${S}
+ patch < ${FILESDIR}/${PV}-Makefile.patch
+
+ # Remove the pesky checks about SSL stuff
+ cd ${S}
+ cp Makefile Makefile.orig
+ grep -v 'read.*exit 1' <Makefile.orig >Makefile
+}
+
+src_compile() {
+ if use ssl; then
+ make lnp SSLTYPE=unix || die
+ else
+ make lnp SSLTYPE=none || die
+ fi
+}
+
+src_install() {
+ into /usr
+
+ # Library binary
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ # Headers
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+
+ # Docs
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+}
diff --git a/net-libs/c-client/files/2002d-Makefile.patch b/net-libs/c-client/files/2002d-Makefile.patch
new file mode 100644
index 000000000000..ce0d0b3701b1
--- /dev/null
+++ b/net-libs/c-client/files/2002d-Makefile.patch
@@ -0,0 +1,65 @@
+--- Makefile~ 2003-04-16 17:32:42.000000000 -0700
++++ Makefile 2003-05-31 19:58:50.000000000 -0700
+@@ -256,7 +256,7 @@
+
+ # Make the IMAP Toolkit
+
+-all: SPECIALS c-client rebuild bundled
++all: SPECIALS c-client rebuild
+
+ c-client:
+ @echo Not processed yet. In a first-time build, you must specify
+@@ -448,16 +448,9 @@
+ $(TOOLS)/$@ "$(LN)" src/ansilib c-client
+ $(TOOLS)/$@ "$(LN)" src/charset c-client
+ $(TOOLS)/$@ "$(LN)" src/osdep/$(SYSTEM) c-client
+- $(TOOLS)/$@ "$(LN)" src/mtest mtest
+- $(TOOLS)/$@ "$(LN)" src/ipopd ipopd
+- $(TOOLS)/$@ "$(LN)" src/imapd imapd
+- $(TOOLS)/$@ "$(LN)" src/mailutil mailutil
+- $(TOOLS)/$@ "$(LN)" src/mlock mlock
+- $(TOOLS)/$@ "$(LN)" src/dmail dmail
+- $(TOOLS)/$@ "$(LN)" src/tmail tmail
+ $(LN) $(TOOLS)/$@ .
+
+-build: OSTYPE rebuild rebuildclean bundled
++build: OSTYPE rebuild rebuildclean
+
+ OSTYPE:
+ @echo Building c-client for $(BUILDTYPE)...
+@@ -472,8 +465,6 @@
+ echo $(BUILDTYPE) > OSTYPE
+ $(TOUCH) rebuild
+
+-rebuild:
+- @$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
+ @echo Rebuilding c-client for `$(CAT) OSTYPE`...
+ @$(TOUCH) SPECIALS
+ $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
+@@ -482,26 +473,6 @@
+ rebuildclean:
+ $(SH) -c '$(RM) rebuild || true'
+
+-bundled:
+- @echo Building bundled tools...
+- $(CD) mtest;$(MAKE)
+- $(CD) ipopd;$(MAKE)
+- $(CD) imapd;$(MAKE)
+- $(CD) mailutil;$(MAKE)
+- @$(SH) -c '(test -f /usr/include/sysexits.h ) || make sysexitwarn'
+- $(CD) mlock;$(MAKE) || true
+- $(CD) dmail;$(MAKE) || true
+- $(CD) tmail;$(MAKE) || true
+-
+-
+-sysexitwarn:
+- @echo Hmm...it does not look like /usr/include/sysexits.h exists.
+- @echo Either your system is too ancient to have the sysexits.h
+- @echo include, or your C compiler gets it from some other location
+- @echo than /usr/include. If your system is too old to have the
+- @echo sysexits.h include, you will not be able to build the
+- @echo following programs.
+-
+ clean:
+ @echo Removing old processed sources and binaries...
+ $(SH) -c '$(RM) an ua OSTYPE SPECIALS c-client mtest imapd ipopd mailutil mlock dmail tmail || true'
diff --git a/net-libs/c-client/files/digest-c-client-2002d b/net-libs/c-client/files/digest-c-client-2002d
new file mode 100644
index 000000000000..7e0aec37a891
--- /dev/null
+++ b/net-libs/c-client/files/digest-c-client-2002d
@@ -0,0 +1 @@
+MD5 64e82a195d21481fc4c54c4ed9fe0527 imap-2002d.tar.Z 2155224