summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-03-05 13:28:24 +0000
committerMarinus Schraal <foser@gentoo.org>2003-03-05 13:28:24 +0000
commita47e37b56307c244e9231c719e957bca1cb23f72 (patch)
tree52d274d9956ecaef8d46b6bcfef8638ec898407e /net-irc
parentmark x86 (diff)
downloadhistorical-a47e37b56307c244e9231c719e957bca1cb23f72.tar.gz
historical-a47e37b56307c244e9231c719e957bca1cb23f72.tar.bz2
historical-a47e37b56307c244e9231c719e957bca1cb23f72.zip
and back in, stable x86 gtk2 version
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.01
-rw-r--r--net-irc/xchat/xchat-2.0.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-2.0.0 b/net-irc/xchat/files/digest-xchat-2.0.0
new file mode 100644
index 000000000000..d6b76da19fba
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.0.0
@@ -0,0 +1 @@
+MD5 4751c5ccb398060c12835dd37768d8d8 xchat-2.0.0.tar.bz2 703788
diff --git a/net-irc/xchat/xchat-2.0.0.ebuild b/net-irc/xchat/xchat-2.0.0.ebuild
new file mode 100644
index 000000000000..068e28bd6216
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.0.ebuild,v 1.4 2003/03/05 13:28:24 foser Exp $
+
+IUSE="perl tcltk python ssl gtk mmx ipv6"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ perl? ( >=sys-devel/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_compile() {
+ local myopts
+
+ use gtk \
+ && myopts="${myopts} --enable-gtkfe" \
+ || myopts="${myopts} --disable-gtkfe"
+ use ssl \
+ && myopts="${myopts} --enable-openssl" \
+ || myopts="${myopts} --disable-openssl"
+ use perl \
+ && myopts="${myopts} --enable-perl" \
+ || myopts="${myopts} --disable-perl"
+ use python \
+ && myopts="${myopts} --enable-python" \
+ || myopts="${myopts} --disable-python"
+ use tcltk \
+ && myopts="${myopts} --enable-tcl" \
+ || myopts="${myopts} --disable-tcl"
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6" \
+ || myopts="${myopts} --disable-ipv6"
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ dodoc AUTHORS COPYING ChangeLog README*
+}