summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-10-15 23:39:18 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-10-15 23:39:18 +0000
commit54d53231d775f502b7126bb35727b3af43fa6589 (patch)
tree3d0ef4dd972a675794a3c637a514287dc79421ea /net-irc
parentIncrementally getting it right. . .. Config files in /etc/mgetty+sendfax, no... (diff)
downloadhistorical-54d53231d775f502b7126bb35727b3af43fa6589.tar.gz
historical-54d53231d775f502b7126bb35727b3af43fa6589.tar.bz2
historical-54d53231d775f502b7126bb35727b3af43fa6589.zip
new version, just a copy from 1.8.2-r3
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.41
-rw-r--r--net-irc/xchat/xchat-1.8.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.8.4 b/net-irc/xchat/files/digest-xchat-1.8.4
new file mode 100644
index 000000000000..508d691b2944
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.4
@@ -0,0 +1 @@
+MD5 87bd6db405a9fcacdf198287f6c3b833 xchat-1.8.4.tar.bz2
diff --git a/net-irc/xchat/xchat-1.8.4.ebuild b/net-irc/xchat/xchat-1.8.4.ebuild
new file mode 100644
index 000000000000..a96d51141576
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.4.ebuild
@@ -0,0 +1,59 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.4.ebuild,v 1.1 2001/10/15 23:39:18 lordjoe Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat irc client"
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ perl? ( sys-devel/perl )
+ python? ( >=dev-lang/python-2.0-r4 )
+ nls? ( >=sys-devel/gettext-0.10.38 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ local myopts myflags
+
+ use gnome && myopts="--enable-gnome --enable-panel"
+ use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
+ use ssl && myopts="$myopts --enable-openssl"
+ use perl || myopts="$myopts --disable-perl"
+ use python && myflags="`python-config --libs` -lm"
+ use python || myopts="$myopts --disable-python"
+ use nls || myopts="$myopts --disable-nls"
+
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
+
+ if [ "$myflags" ] ; then
+ for i in src/fe-gtk src/fe-text
+ do
+ if [ -e $i/Makefile ] ; then
+ cp $i/Makefile $i/Makefile.orig
+ sed -e "s:-lpython2.0:$myflags:" \
+ $i/Makefile.orig > $i/Makefile
+ fi
+ done
+ fi
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS COPYING ChangeLog README
+}