summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-23 01:00:39 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-23 01:00:39 +0000
commit087211d83ab3710855c312dfcaace622e58f9875 (patch)
tree765b87ad37220c9b56bff48fe2f4af897ca6e1b6 /net-irc
parenta fix for automake's package.mask (later revs were getting masked out) (diff)
downloadhistorical-087211d83ab3710855c312dfcaace622e58f9875.tar.gz
historical-087211d83ab3710855c312dfcaace622e58f9875.tar.bz2
historical-087211d83ab3710855c312dfcaace622e58f9875.zip
updates
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bitchx/bitchx-1.0.18-r2.ebuild83
-rw-r--r--net-irc/bitchx/files/bitchx-1.0.18-r2-gentoo.diff31
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.0.18-r21
-rw-r--r--net-irc/epic4/files/digest-epic4-1.0.1-r12
4 files changed, 117 insertions, 0 deletions
diff --git a/net-irc/bitchx/bitchx-1.0.18-r2.ebuild b/net-irc/bitchx/bitchx-1.0.18-r2.ebuild
new file mode 100644
index 000000000000..85ca2cf5e8e5
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.0.18-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.18-r2.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+
+P=
+A=ircii-pana-1.0c18.tar.gz
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${A}"
+HOMEPAGE="http://www.bitchx.com/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=dev-libs/openssl-0.9.6
+ gnome? ( >=gnome-base/gnome-libs-1.2.4
+ >=media-sound/esound-0.2.22 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--with-gtk --with-sound --prefix=/opt/gnome --with-esd"
+ else
+ myopts="--prefix=/usr"
+ fi
+ try ./configure ${myopts} --host=${CHOST} \
+ --enable-cdrom --with-plugins
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ insinto /opt/gnome/share/gnome/apps/Internet
+ doins gtkBitchX.desktop
+ insinto /opt/gnome/share/pixmaps
+ doins BitchX.png
+ else
+ try make prefix=${D}/usr install
+ fi
+
+ ln -sf ${D}/usr/bin/${P} BitchX
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+
+ dodoc Changelog README* IPv6-support
+ cd doc
+ insinto /usr/X11R6/include/bitmaps
+ doins BitchX.xpm
+
+ dodoc BitchX-* BitchX.bot *.doc BitchX.faq README.hooks
+ dodoc bugs *.txt functions ideas mode tcl-ideas watch
+ dodoc *.tcl
+ docinto html
+ dodoc *.html
+
+ docinto plugins
+ dodoc plugins
+ cd ../dll
+ insinto /usr/lib/bx/wav
+ doins wavplay/*.wav
+ mv acro/README acro/README.acro
+ dodoc acro/README.acro
+ mv arcfour/README arcfour/README.arcfour
+ dodoc arcfour/README.arcfour
+ mv blowfish/README blowfish/README.blowfish
+ dodoc blowfish/README.blowfish
+ dodoc nap/README.nap
+ mv qbx/README qbx/README.qbx
+ dodoc qbx/README.qbx
+}
diff --git a/net-irc/bitchx/files/bitchx-1.0.18-r2-gentoo.diff b/net-irc/bitchx/files/bitchx-1.0.18-r2-gentoo.diff
new file mode 100644
index 000000000000..034b395952d9
--- /dev/null
+++ b/net-irc/bitchx/files/bitchx-1.0.18-r2-gentoo.diff
@@ -0,0 +1,31 @@
+diff -ur BitchX.orig/configure BitchX/configure
+--- BitchX.orig/configure Mon Jan 8 01:24:22 2001
++++ BitchX/configure Tue Apr 17 18:33:57 2001
+@@ -7030,7 +7030,8 @@
+
+ echo "$as_me:7031: checking for ZVT" >&5
+ echo $ECHO_N "checking for ZVT... $ECHO_C" >&6
+- ZVT_LIBS="`$GNOME_CONFIG $gnome_config_args --libs-only-l zvt`"
++ ZVT_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags gnome`"
++ ZVT_LIBS="`$GNOME_CONFIG $gnome_config_args --libs zvt`"
+ if test x"$ZVT_LIBS" != x""; then
+ echo "$as_me:7035: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+@@ -7097,8 +7098,6 @@
+ G_CFLAGS="$GLIB_CFLAGS $GTK_CFLAGS $GDK_IMLIB_CFLAGS $ZVT_CFLAGS"
+ G_LIBS="$GLIB_LIBS $GTK_LIBS $PTHREAD_LIBS $GDK_IMLIB_LIBS $ZVT_LIBS"
+ fi
+- CFLAGS="$CFLAGS $G_CFLAGS"
+- LIBS="$G_LIBS $LIBS"
+ VERSION="gtk$VERSION"
+ _VERSION_="gtk$_VERSION_"
+
+@@ -11944,6 +11943,8 @@
+ SHLIB_SUFFIX=".so"
+ fi
+
++CFLAGS="$CFLAGS $G_CFLAGS"
++LIBS="$G_LIBS $LIBS"
+ if test x"$GCC" = x"yes" -a -z "`echo "$CFLAGS" | grep \\\-Wall`"; then
+ CFLAGS="$CFLAGS -Wall"
+ fi
diff --git a/net-irc/bitchx/files/digest-bitchx-1.0.18-r2 b/net-irc/bitchx/files/digest-bitchx-1.0.18-r2
new file mode 100644
index 000000000000..3fc29729f1f9
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.0.18-r2
@@ -0,0 +1 @@
+MD5 737276281ae911c5e1e17b028ebee045 ircii-pana-1.0c18.tar.gz
diff --git a/net-irc/epic4/files/digest-epic4-1.0.1-r1 b/net-irc/epic4/files/digest-epic4-1.0.1-r1
new file mode 100644
index 000000000000..39b301db2b47
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-1.0.1-r1
@@ -0,0 +1,2 @@
+MD5 176f77c1e372fc3ca184eca951cb86f5 epic4pre2-help.tar.gz
+MD5 53610020128ba1edb7701a73b778f75f epic4-1.0.1.tar.gz