summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-22 11:57:04 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-22 11:57:04 +0000
commit74efc842cfa6c58d6ff172116aaf004333f32073 (patch)
tree4048a18fe339757d3c89374209d534d49b0def06 /net-irc/bitchx
parentmoved from app-admin (diff)
downloadhistorical-74efc842cfa6c58d6ff172116aaf004333f32073.tar.gz
historical-74efc842cfa6c58d6ff172116aaf004333f32073.tar.bz2
historical-74efc842cfa6c58d6ff172116aaf004333f32073.zip
merge gtk-bitchx and bitchx and look at gnome and esd USE-flags
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/bitchx-1.0.18-r3.ebuild94
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.0.18-r31
2 files changed, 95 insertions, 0 deletions
diff --git a/net-irc/bitchx/bitchx-1.0.18-r3.ebuild b/net-irc/bitchx/bitchx-1.0.18-r3.ebuild
new file mode 100644
index 000000000000..5542eff39d2f
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.0.18-r3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.18-r3.ebuild,v 1.1 2001/09/22 11:57:04 hallski Exp $
+
+A=ircii-pana-1.0c18.tar.gz
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${A}"
+HOMEPAGE="http://www.bitchx.com/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ gnome? ( >=x11-libs/gtk+-1.2.0
+ >=media-libs/imlib-1.9.4
+ >=gnome-base/gnome-libs-1.2 )
+ esd? ( >=media-sound/esound-0.2.5
+ >=media-libs/audiofile-0.1.5 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ local myopts
+
+ if [ -n "`use ssl`" ]
+ then
+ myopts="$myopts --with-ssl"
+ fi
+
+ if [ -n "`use gnome`" ]
+ then
+ myopts="$myopts --with-gtk"
+ fi
+
+ if [ -n "`use esd`" ]
+ then
+ myopts="$myopts --enable-sound"
+ fi
+
+ ./configure --prefix=/usr --host=${CHOST} --build=${CHOST} \
+ --enable-cdrom --enable-ipv6 --with-plugins \
+ --disable-sound ${myopts} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ cd ${D}/usr/bin
+
+ if [ -n "`use gnome`" ]
+ then
+ rm -f gtkBitchX
+ dosym /usr/bin/gtkBitchX-1.0c18 /usr/bin/gtkBitchX
+ dosym /usr/bin/gtkBitchX-1.0c18 /usr/bin/bitchX
+ else
+ rm -f BitchX
+ dosym /usr/bin/BitchX-1.0c18 /usr/bin/BitchX
+ dosym /usr/bin/BitchX-1.0c18 /usr/bin/bitchX
+ fi
+
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+
+ cd ${S}
+ dodoc Changelog README* IPv6-support
+ cd doc
+ insinto /usr/X11R6/include/bitmaps
+ doins BitchX.xpm
+
+ dodoc BitchX-* BitchX.bot *.doc BitchX.faq README.hooks
+ dodoc bugs *.txt functions ideas mode tcl-ideas watch
+ dodoc *.tcl
+ docinto html
+ dodoc *.html
+
+ docinto plugins
+ dodoc plugins
+ cd ../dll
+ insinto /usr/lib/bx/wav
+ doins wavplay/*.wav
+ cp acro/README acro/README.acro
+ dodoc acro/README.acro
+ cp arcfour/README arcfour/README.arcfour
+ dodoc arcfour/README.arcfour
+ cp blowfish/README blowfish/README.blowfish
+ dodoc blowfish/README.blowfish
+ dodoc nap/README.nap
+ cp qbx/README qbx/README.qbx
+ dodoc qbx/README.qbx
+}
diff --git a/net-irc/bitchx/files/digest-bitchx-1.0.18-r3 b/net-irc/bitchx/files/digest-bitchx-1.0.18-r3
new file mode 100644
index 000000000000..3fc29729f1f9
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.0.18-r3
@@ -0,0 +1 @@
+MD5 737276281ae911c5e1e17b028ebee045 ircii-pana-1.0c18.tar.gz