summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-06 07:03:03 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-06 07:03:03 +0000
commit747d8197c00b1714a50ee068c63f85f7a99f9917 (patch)
tree23537d461d1ef8c887179b7e2b22065c9fea4a2c /net-irc/bitchx/files
parentI haven't use icq forever, however I still remember the password i used oh so... (diff)
downloadhistorical-747d8197c00b1714a50ee068c63f85f7a99f9917.tar.gz
historical-747d8197c00b1714a50ee068c63f85f7a99f9917.tar.bz2
historical-747d8197c00b1714a50ee068c63f85f7a99f9917.zip
Clean up ebuild and compiling with gcc-4.1 #113736; thanks to everyone.
Package-Manager: portage-2.1.1_rc1-r4
Diffstat (limited to 'net-irc/bitchx/files')
-rw-r--r--net-irc/bitchx/files/1.1/bitchx-1.1-build.patch53
-rw-r--r--net-irc/bitchx/files/1.1/bitchx-1.1-gcc34.patch8
-rw-r--r--net-irc/bitchx/files/1.1/bitchx-1.1-gcc41.patch119
-rw-r--r--net-irc/bitchx/files/1.1/bitchx-1.1-headers.patch49
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.1-r12
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.1-r22
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.1-r33
7 files changed, 233 insertions, 3 deletions
diff --git a/net-irc/bitchx/files/1.1/bitchx-1.1-build.patch b/net-irc/bitchx/files/1.1/bitchx-1.1-build.patch
new file mode 100644
index 000000000000..45de9cc6014f
--- /dev/null
+++ b/net-irc/bitchx/files/1.1/bitchx-1.1-build.patch
@@ -0,0 +1,53 @@
+dll/aim/Makefile.in: Fix parallel building
+
+dll/hint/Makefile.in: BitchX.hints is a data file, not a plugin
+
+dll/Makefile.in: Let portage do the stripping
+
+Makefile.in: Let portage do the compression
+
+--- dll/aim/Makefile.in
++++ dll/aim/Makefile.in
+@@ -184,7 +184,7 @@
+ aim.o: $(srcdir)/aim.c
+ $(CC) $(AIMDEFS) $(CFLAGS) $(SHLIB_CFLAGS) -c $(srcdir)/aim.c
+
+-aim$(SHLIB_SUFFIX): $(OBJS)
++aim$(SHLIB_SUFFIX): $(OBJS) toc
+ $(SHLIB_LD) $(OBJS) $(SHLIB_CFLAGS) -o aim$(SHLIB_SUFFIX) -Ltoc -ltoc
+
+ dummy:
+--- dll/hint/Makefile.in
++++ dll/hint/Makefile.in
+@@ -178,4 +178,4 @@
+
+ install:
+ $(INSTALL) $(PLUGIN_NAME)$(SHLIB_SUFFIX) $(PLUGINDIR)
+- $(INSTALL) $(srcdir)/BitchX.hints $(PLUGINDIR)/@HINT_FILE@
++ $(INSTALL_DATA) $(srcdir)/BitchX.hints $(PLUGINDIR)/@HINT_FILE@
+--- dll/Makefile.in
++++ dll/Makefile.in
+@@ -206,12 +206,6 @@
+ || case "$$makeflags" in *=*) exit 1;; *k*) ;; *) exit 1;; esac; \
+ done; \
+ )
+- @( \
+- if test x"$(PLUGINS)" != x""; then \
+- strip --strip-unneeded $(PLUGINDIR)/*$(SHLIB_SUFFIX) || :; \
+- echo Your plugins [$(PLUGINS)] are now located in $(PLUGINDIR);\
+- fi; \
+- )
+
+ install_local: all
+ $(INSTALL) -d $(local_dir)/.BitchX/plugins
+--- Makefile.in
++++ Makefile.in
+@@ -302,8 +298,6 @@
+ done; \
+ fi; \
+ )
+- (find $(mandir)/man1/BitchX.1 -type f ! -name '*.bz2' ! -name '*.gz' -name '*' | \
+- (xargs bzip2 -9f || xargs gzip -9f) || :) 2>/dev/null
+
+ installdirs:
+ umask 022; $(top_srcdir)/mkinstalldirs $(bindir) $(IRCLIB) $(mandir)/man1 $(TRANSLATION_PATH) $(INSTALL_SCRIPT) $(HELPDIR)
diff --git a/net-irc/bitchx/files/1.1/bitchx-1.1-gcc34.patch b/net-irc/bitchx/files/1.1/bitchx-1.1-gcc34.patch
index 642e9eed6920..db549a6824ca 100644
--- a/net-irc/bitchx/files/1.1/bitchx-1.1-gcc34.patch
+++ b/net-irc/bitchx/files/1.1/bitchx-1.1-gcc34.patch
@@ -1,13 +1,15 @@
---- source/term.c.orig 2004-06-19 21:40:36.757653368 +0000
-+++ source/term.c 2004-06-19 21:41:31.783563978 +0000
-@@ -91,8 +91,8 @@
+--- source/term.c
++++ source/term.c
+@@ -91,8 +91,10 @@
#define Tgetflag(x) tgetflag(x.tname)
#endif
-extern char *getenv();
-extern char *tparm();
+extern char *getenv(const char *name);
++#ifndef TPARM_DECLARED
+extern char *tparm(char *str, ...);
++#endif
/*
* The old code assumed termcap. termcap is almost always present, but on
diff --git a/net-irc/bitchx/files/1.1/bitchx-1.1-gcc41.patch b/net-irc/bitchx/files/1.1/bitchx-1.1-gcc41.patch
new file mode 100644
index 000000000000..065198818cb1
--- /dev/null
+++ b/net-irc/bitchx/files/1.1/bitchx-1.1-gcc41.patch
@@ -0,0 +1,119 @@
+GCC 4.0 is more picky about static declarations for variables previously
+declared non-static.
+
+From Andreas Jochens <aj@andaco.de>, for Debian bug #290365.
+
+ dll/aim/toc/server.c | 4 ++--
+ dll/aim/toc/toc.c | 6 +++---
+ include/modval.h | 16 ++++++++--------
+ source/ctcp.c | 2 +-
+ source/timer.c | 2 +-
+ 5 files changed, 15 insertions(+), 15 deletions(-)
+
+Index: ircii-pana-1.1/dll/aim/toc/server.c
+===================================================================
+--- ircii-pana-1.1.orig/dll/aim/toc/server.c 2003-04-10 21:09:06.000000000 -0400
++++ ircii-pana-1.1/dll/aim/toc/server.c 2005-07-27 22:34:21.000000000 -0400
+@@ -7,14 +7,14 @@
+ #include <unistd.h>
+ #include "toc.h"
+
+-static time_t lastsent = 0;
++time_t lastsent = 0;
+ time_t login_time = 0;
+ int my_evil;
+ int is_idle = 0;
+ int lag_ms = 0;
+ int time_to_idle = 600;
+ int is_away = 0;
+-static struct timeval lag_tv;
++struct timeval lag_tv;
+
+ void serv_add_buddy(char *name)
+ {
+Index: ircii-pana-1.1/dll/aim/toc/toc.c
+===================================================================
+--- ircii-pana-1.1.orig/dll/aim/toc/toc.c 2003-04-10 21:09:06.000000000 -0400
++++ ircii-pana-1.1/dll/aim/toc/toc.c 2005-07-27 22:34:21.000000000 -0400
+@@ -39,9 +39,9 @@
+ #include "toc.h"
+
+ /* descriptor for talking to TOC */
+-static int toc_fd;
+-static int seqno;
+-static unsigned int peer_ver=0;
++int toc_fd;
++int seqno;
++unsigned int peer_ver=0;
+ int state;
+ /* static int inpa=-1; */
+ int permdeny = PERMIT_PERMITALL;
+Index: ircii-pana-1.1/include/modval.h
+===================================================================
+--- ircii-pana-1.1.orig/include/modval.h 2003-04-10 21:09:07.000000000 -0400
++++ ircii-pana-1.1/include/modval.h 2005-07-27 22:34:21.000000000 -0400
+@@ -650,7 +650,7 @@ extern Function_ptr *global;
+ #define start_time ((time_t) *((time_t *)global[START_TIME]))
+ #define idle_time() ((time_t) *((time_t *)global[IDLE_TIME]()))
+
+-#define loading_global ((int) *((int *)global[LOADING_GLOBAL]))
++#define loading_global (*((int *)global[LOADING_GLOBAL]))
+ #define target_window (*((Window **)global[TARGET_WINDOW]))
+ #define current_window (*((Window **)global[CURRENT_WINDOW]))
+ #define invisible_list (*((Window **)global[INVISIBLE_LIST]))
+@@ -665,12 +665,12 @@ extern Function_ptr *global;
+ #define dll_variable (*((IrcVariableDll **)global[DLL_VARIABLE]))
+ #define dll_ctcp (*((CtcpEntryDll **)global[DLL_CTCP]))
+ #define dll_window (*((WindowDll **)global[DLL_WINDOW]))
+-#define window_display ((int) *((int *)global[WINDOW_DISPLAY]))
+-#define status_update_flag ((int) *((int *)global[STATUS_UPDATE_FLAG]))
++#define window_display (*((int *)global[WINDOW_DISPLAY]))
++#define status_update_flag (*((int *)global[STATUS_UPDATE_FLAG]))
+ #define tabkey_array (*((NickTab **)global[TABKEY_ARRAY]))
+ #define autoreply_array (*((NickTab *)global[AUTOREPLY_ARRAY]))
+-#define identd ((int) *((int *)global[IDENTD_SOCKET]))
+-#define doing_notice ((int) *((int *)global[DOING_NOTICE]))
++#define identd (*((int *)global[IDENTD_SOCKET]))
++#define doing_notice (*((int *)global[DOING_NOTICE]))
+ #define last_sent_msg_body (*((char **)global[LAST_SENT_MSG_BODY]))
+ #define sent_nick (*((char **)global[SENT_NICK]))
+
+@@ -698,9 +698,9 @@ extern Function_ptr *global;
+ #ifdef GUI
+ #ifndef MAIN_SOURCE
+ #define lastclicklinedata ((char *) *global[LASTCLICKLINEDATA])
+-#define contextx ((int) *((int *)global[CONTEXTX]))
+-#define contexty ((int) *((int *)global[CONTEXTY]))
+-#define guiipc ((int) *((int *)global[GUIIPC]))
++#define contextx (*((int *)global[CONTEXTX]))
++#define contexty (*((int *)global[CONTEXTY]))
++#define guiipc (*((int *)global[GUIIPC]))
+ #endif
+ #define gui_mutex_lock() ((void (*)(void)) global[GUI_MUTEX_LOCK])()
+ #define gui_mutex_unlock() ((void (*)(void))global[GUI_MUTEX_UNLOCK])()
+Index: ircii-pana-1.1/source/ctcp.c
+===================================================================
+--- ircii-pana-1.1.orig/source/ctcp.c 2003-05-27 03:00:22.000000000 -0400
++++ ircii-pana-1.1/source/ctcp.c 2005-07-27 22:34:21.000000000 -0400
+@@ -176,7 +176,7 @@ CtcpEntryDll *dll_ctcp = NULL;
+
+ /* CDE do ops and unban logging */
+
+-static char *ctcp_type[] =
++char *ctcp_type[] =
+ {
+ "PRIVMSG",
+ "NOTICE"
+Index: ircii-pana-1.1/source/timer.c
+===================================================================
+--- ircii-pana-1.1.orig/source/timer.c 2003-04-10 21:09:07.000000000 -0400
++++ ircii-pana-1.1/source/timer.c 2005-07-27 22:34:21.000000000 -0400
+@@ -148,7 +148,7 @@ BUILT_IN_COMMAND(timercmd)
+ * This is put here on purpose -- we dont want any of the above functions
+ * to have any knowledge of this struct.
+ */
+-static TimerList *PendingTimers;
++TimerList *PendingTimers;
+ static char *schedule_timer (TimerList *ntimer);
+
+ static char *current_exec_timer = empty_string;
diff --git a/net-irc/bitchx/files/1.1/bitchx-1.1-headers.patch b/net-irc/bitchx/files/1.1/bitchx-1.1-headers.patch
new file mode 100644
index 000000000000..e28552260192
--- /dev/null
+++ b/net-irc/bitchx/files/1.1/bitchx-1.1-headers.patch
@@ -0,0 +1,49 @@
+--- ./dll/aim/toc/interface.c
++++ ./dll/aim/toc/interface.c
+@@ -8,6 +8,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <time.h>
+ #include "toc.h"
+
+--- ./dll/possum/llist.c
++++ ./dll/possum/llist.c
+@@ -1,4 +1,5 @@
+ #include <stdlib.h>
++#include <string.h>
+ #include "llist.h"
+
+ llist *lmake(size_t size) {
+--- ./dll/europa/europa.c
++++ ./dll/europa/europa.c
+@@ -5,6 +5,8 @@
+ the file COPYING for details.
+ */
+
++#include <string.h>
++
+ #define MOD_VERSION "0.01"
+ #define MOD_NAME "Europa"
+ #include "europa.h"
+--- ./dll/arcfour/md5.c
++++ ./dll/arcfour/md5.c
+@@ -1,5 +1,6 @@
+ /* MD5 Message Digest algorithm */
+
++#include <string.h>
+ #include "md5.h"
+
+ /* Prototypes */
+--- contrib/vh1.c
++++ contrib/vh1.c
+@@ -30,6 +30,8 @@
+ #include <netinet/in.h>
+ #if !defined(linux)
+ #include <netinet/in_var.h>
++#else
++#include <arpa/inet.h>
+ #endif
+ #include <netdb.h>
+
diff --git a/net-irc/bitchx/files/digest-bitchx-1.1-r1 b/net-irc/bitchx/files/digest-bitchx-1.1-r1
index 3967cc2f290d..5721630b3fc2 100644
--- a/net-irc/bitchx/files/digest-bitchx-1.1-r1
+++ b/net-irc/bitchx/files/digest-bitchx-1.1-r1
@@ -1 +1,3 @@
MD5 611d2dda222f00c10140236f4c331572 ircii-pana-1.1-final.tar.gz 2532476
+RMD160 4105de2587964146e2391a26a8a16e3d0059a93f ircii-pana-1.1-final.tar.gz 2532476
+SHA256 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57 ircii-pana-1.1-final.tar.gz 2532476
diff --git a/net-irc/bitchx/files/digest-bitchx-1.1-r2 b/net-irc/bitchx/files/digest-bitchx-1.1-r2
index 3967cc2f290d..5721630b3fc2 100644
--- a/net-irc/bitchx/files/digest-bitchx-1.1-r2
+++ b/net-irc/bitchx/files/digest-bitchx-1.1-r2
@@ -1 +1,3 @@
MD5 611d2dda222f00c10140236f4c331572 ircii-pana-1.1-final.tar.gz 2532476
+RMD160 4105de2587964146e2391a26a8a16e3d0059a93f ircii-pana-1.1-final.tar.gz 2532476
+SHA256 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57 ircii-pana-1.1-final.tar.gz 2532476
diff --git a/net-irc/bitchx/files/digest-bitchx-1.1-r3 b/net-irc/bitchx/files/digest-bitchx-1.1-r3
new file mode 100644
index 000000000000..5721630b3fc2
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.1-r3
@@ -0,0 +1,3 @@
+MD5 611d2dda222f00c10140236f4c331572 ircii-pana-1.1-final.tar.gz 2532476
+RMD160 4105de2587964146e2391a26a8a16e3d0059a93f ircii-pana-1.1-final.tar.gz 2532476
+SHA256 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57 ircii-pana-1.1-final.tar.gz 2532476