summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-12-15 12:49:23 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-12-15 12:49:23 +0000
commit0b4497b907a87afb4a145e6daec8ffd5841b4244 (patch)
treeef14b9f191149b8db75e313c781328f722b61e62 /net-ftp
parentlast but not least glibc 2.3.1-2 on alpha is stable (diff)
downloadhistorical-0b4497b907a87afb4a145e6daec8ffd5841b4244.tar.gz
historical-0b4497b907a87afb4a145e6daec8ffd5841b4244.tar.bz2
historical-0b4497b907a87afb4a145e6daec8ffd5841b4244.zip
Version bump
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/ChangeLog7
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.2.73
-rw-r--r--net-ftp/proftpd/proftpd-1.2.7.ebuild146
3 files changed, 155 insertions, 1 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index aab03f7ca5c5..d520f21b8db5 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.17 2002/12/13 10:59:56 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.18 2002/12/15 12:49:23 aliz Exp $
+
+*proftpd-1.2.7 (15 Dec 2002)
+
+ 15 Dec 2002; Daniel Ahlberg <aliz@gentoo.org> proftpd-1.2.7.ebuild :
+ Version bump.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.2.7 b/net-ftp/proftpd/files/digest-proftpd-1.2.7
new file mode 100644
index 000000000000..6ce489566016
--- /dev/null
+++ b/net-ftp/proftpd/files/digest-proftpd-1.2.7
@@ -0,0 +1,3 @@
+MD5 7f2f7890742255e703437046149a1c31 proftpd-1.2.7.tar.bz2 646680
+MD5 eabad809f05fe633b3ae421170ce7453 proftpd-mod-tls-2.0.4.tar.gz 47978
+MD5 4976b4762675380e173527dea9dc7539 proftpd-mod-wrap-1.2.3.tar.gz 12652
diff --git a/net-ftp/proftpd/proftpd-1.2.7.ebuild b/net-ftp/proftpd/proftpd-1.2.7.ebuild
new file mode 100644
index 000000000000..da51f31834dd
--- /dev/null
+++ b/net-ftp/proftpd/proftpd-1.2.7.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.7.ebuild,v 1.1 2002/12/15 12:49:23 aliz Exp $
+
+IUSE="ldap pam postgres mysql ssl tcpd"
+
+TLS_VER="2.0.4"
+WRAP_VER="1.2.3"
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An advanced and very configurable FTP server"
+SRC_URI="ftp://ftp.proftpd.org/distrib/source/${MY_P}.tar.bz2
+ ssl? ( http://www.castaglia.org/proftpd/modules/proftpd-mod-tls-${TLS_VER}.tar.gz )
+ tcpd? ( http://www.castaglia.org/proftpd/modules/proftpd-mod-wrap-${WRAP_VER}.tar.gz )"
+HOMEPAGE="http://www.proftpd.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="net-libs/libpcap
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r3 )"
+
+src_unpack() {
+
+ unpack ${MY_P}.tar.bz2
+
+ cd ${S}
+
+ if use ssl; then
+ unpack proftpd-mod-tls-${TLS_VER}.tar.gz
+ cp mod_tls/mod_tls.c modules
+ fi
+
+ if use tcpd; then
+ unpack proftpd-mod-wrap-${WRAP_VER}.tar.gz
+ cp mod_wrap/mod_wrap.c modules
+ fi
+}
+
+
+src_compile() {
+ local modules myconf
+
+ modules="mod_ratio:mod_readme"
+ use x86 && modules="${modules}:mod_linuxprivs"
+ use pam && modules="${modules}:mod_pam"
+ use tcpd && modules="${modules}:mod_wrap"
+
+ if use ldap; then
+ einfo ldap
+ modules="${modules}:mod_ldap"
+ export LDFLAGS="-lresolv"
+ fi
+
+ if use ssl; then
+ einfo ssl
+ # enable TLS for mod_ldap
+ cp contrib/mod_ldap.c contrib/mod_ldap.c.orig
+ sed -e "s:\/\* #define USE_LDAPV3_TLS \*\/:#define USE_LDAPV3_TLS:" \
+ -e "s:\/\* #define HAVE_OPENSSL \*\/:#define HAVE_OPENSSL:" \
+ contrib/mod_ldap.c.orig > contrib/mod_ldap.c || die "sed failed"
+
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ fi
+
+ if use mysql; then
+ modules="${modules}:mod_sql:mod_sql_mysql"
+ elif use postgres; then
+ modules="${modules}:mod_sql:mod_sql_postgres"
+ myconf="--with-includes=/usr/include/postgresql"
+ fi
+
+ econf \
+ --sbindir=/usr/sbin \
+ --localstatedir=/var/run \
+ --sysconfdir=/etc/proftpd \
+ --enable-shadow \
+ --disable-sendfile \
+ --enable-autoshadow \
+ --with-modules=${modules} \
+ ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ # Note rundir needs to be specified to avoid sandbox violation
+ # on initial install. See Make.rules
+ einstall \
+ sbindir=${D}/usr/sbin \
+ localstatedir=${D}/var/run \
+ rundir=${D}/var/run/proftpd \
+ sysconfdir=${D}/etc/proftpd \
+ || die
+
+ keepdir /home/ftp
+ keepdir /var/run/proftpd
+
+ dodoc contrib/README.mod_sql ${FILESDIR}/proftpd.conf \
+ COPYING CREDITS ChangeLog NEWS README* \
+ doc/{license.txt,GetConf}
+ dohtml doc/*.html
+ docinto rfc
+ dodoc doc/rfc/*.txt
+
+ if use ssl; then
+ docinto mod_tls-${TLS_VER}
+ dodoc mod_tls/{README,draft-murray-auth-ftp-ssl-09.txt}
+ dohtml mod_tls/mod_tls.html
+ fi
+
+ if use tcpd; then
+ docinto mod_wrap-${WRAP_VER}
+ dodoc mod_wrap/README
+ dohtml mod_wrap/mod_wrap.html
+ fi
+
+ mv ${D}/etc/proftpd/proftpd.conf ${D}/etc/proftpd/proftpd.conf.distrib
+
+ insinto /etc/proftpd
+ newins ${FILESDIR}/proftpd.conf proftpd.conf.sample
+
+ if use pam; then
+ insinto /etc/pam.d
+ newins ${S}/contrib/dist/rpm/ftp.pamd ftp
+ fi
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/proftpd.xinetd proftpd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/proftpd.rc6 proftpd
+}
+
+pkg_postinst() {
+ groupadd proftpd &>/dev/null
+ id proftpd &>/dev/null || \
+ useradd -g proftpd -d /home/ftp -s /bin/false proftpd
+}