summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-02-15 16:43:43 +0000
committerDonny Davies <woodchip@gentoo.org>2003-02-15 16:43:43 +0000
commitecc6389f14c9d1115a61e9656e5f41ebabc15a61 (patch)
tree3b676821b0d13caab6983c57b8b229bdb108f719 /net-ftp/vsftpd
parentnew version (diff)
downloadhistorical-ecc6389f14c9d1115a61e9656e5f41ebabc15a61.tar.gz
historical-ecc6389f14c9d1115a61e9656e5f41ebabc15a61.tar.bz2
historical-ecc6389f14c9d1115a61e9656e5f41ebabc15a61.zip
add pam & tcpd support
Diffstat (limited to 'net-ftp/vsftpd')
-rw-r--r--net-ftp/vsftpd/ChangeLog16
-rw-r--r--net-ftp/vsftpd/files/digest-vsftpd-1.1.31
-rw-r--r--net-ftp/vsftpd/files/vsftpd-1.1.3-gentoo.diff173
-rw-r--r--net-ftp/vsftpd/vsftpd-1.1.3.ebuild57
4 files changed, 237 insertions, 10 deletions
diff --git a/net-ftp/vsftpd/ChangeLog b/net-ftp/vsftpd/ChangeLog
index dd3339c02552..54caba6b9f7f 100644
--- a/net-ftp/vsftpd/ChangeLog
+++ b/net-ftp/vsftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/vsftpd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/vsftpd/ChangeLog,v 1.7 2003/02/12 07:59:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/vsftpd/ChangeLog,v 1.8 2003/02/15 16:43:43 woodchip Exp $
+
+*vsftpd-1.1.3 (15 Feb 2003)
+
+ 15 Feb 2003; Donny Davies <woodchip@gentoo.org> : Chase latest release.
+ #12435; optional pam and tcpd support.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
@@ -16,12 +21,3 @@
3 May 2002; Donny Davies <woodchip@gentoo.org> :
Added LICENSE, SLOT.
-
-*vsftpd-1.0.1 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/net-ftp/vsftpd/files/digest-vsftpd-1.1.3 b/net-ftp/vsftpd/files/digest-vsftpd-1.1.3
new file mode 100644
index 000000000000..62a9cd324075
--- /dev/null
+++ b/net-ftp/vsftpd/files/digest-vsftpd-1.1.3
@@ -0,0 +1 @@
+MD5 3f5f59be09a6f89e516a75ad0d1e3802 vsftpd-1.1.3.tar.gz 120817
diff --git a/net-ftp/vsftpd/files/vsftpd-1.1.3-gentoo.diff b/net-ftp/vsftpd/files/vsftpd-1.1.3-gentoo.diff
new file mode 100644
index 000000000000..6f1fa7337932
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd-1.1.3-gentoo.diff
@@ -0,0 +1,173 @@
+diff -uNr vsftpd-1.1.3.orig/defs.h vsftpd-1.1.3/defs.h
+--- vsftpd-1.1.3.orig/defs.h 2002-07-09 18:51:57.000000000 -0400
++++ vsftpd-1.1.3/defs.h 2003-02-15 11:19:48.000000000 -0500
+@@ -1,7 +1,7 @@
+ #ifndef VSF_DEFS_H
+ #define VSF_DEFS_H
+
+-#define VSFTP_DEFAULT_CONFIG "/etc/vsftpd.conf"
++#define VSFTP_DEFAULT_CONFIG "/etc/vsftpd/vsftpd.conf"
+
+ #define VSFTP_COMMAND_FD 0
+
+diff -uNr vsftpd-1.1.3.orig/sysdeputil.c vsftpd-1.1.3/sysdeputil.c
+--- vsftpd-1.1.3.orig/sysdeputil.c 2002-10-29 20:06:41.000000000 -0500
++++ vsftpd-1.1.3/sysdeputil.c 2003-02-15 11:21:17.000000000 -0500
+@@ -39,7 +39,9 @@
+ #undef VSF_SYSDEP_HAVE_HPUX_SETPROCTITLE
+ #undef VSF_SYSDEP_HAVE_MAP_ANON
+ #undef VSF_SYSDEP_NEED_OLD_FD_PASSING
+-#define VSF_SYSDEP_HAVE_PAM
++#ifdef USE_PAM
++ #define VSF_SYSDEP_HAVE_PAM
++#endif
+ #define VSF_SYSDEP_HAVE_SHADOW
+ #define VSF_SYSDEP_HAVE_USERSHELL
+ #define VSF_SYSDEP_HAVE_LIBCAP
+diff -uNr vsftpd-1.1.3.orig/tunables.c vsftpd-1.1.3/tunables.c
+--- vsftpd-1.1.3.orig/tunables.c 2002-10-24 18:46:21.000000000 -0400
++++ vsftpd-1.1.3/tunables.c 2003-02-15 11:19:48.000000000 -0500
+@@ -65,19 +65,19 @@
+ unsigned int tunable_file_open_mode = 0666;
+ unsigned int tunable_max_per_ip = 0;
+
+-const char* tunable_secure_chroot_dir = "/usr/share/empty";
++const char* tunable_secure_chroot_dir = "/usr/share/vsftpd/empty";
+ const char* tunable_ftp_username = "ftp";
+ const char* tunable_chown_username = "root";
+-const char* tunable_xferlog_file = "/var/log/vsftpd.log";
++const char* tunable_xferlog_file = "/var/log/vsftpd/vsftpd.log";
+ const char* tunable_message_file = ".message";
+ /* XXX -> "secure"? */
+ const char* tunable_nopriv_user = "nobody";
+ const char* tunable_ftpd_banner = 0;
+-const char* tunable_banned_email_file = "/etc/vsftpd.banned_emails";
+-const char* tunable_chroot_list_file = "/etc/vsftpd.chroot_list";
+-const char* tunable_pam_service_name = "ftp";
++const char* tunable_banned_email_file = "/etc/vsftpd/vsftpd.banned_emails";
++const char* tunable_chroot_list_file = "/etc/vsftpd/vsftpd.chroot_list";
++const char* tunable_pam_service_name = "vsftpd";
+ const char* tunable_guest_username = "ftp";
+-const char* tunable_userlist_file = "/etc/vsftpd.user_list";
++const char* tunable_userlist_file = "/etc/vsftpd/vsftpd.user_list";
+ const char* tunable_anon_root = 0;
+ const char* tunable_local_root = 0;
+ const char* tunable_banner_file = 0;
+diff -uNr vsftpd-1.1.3.orig/vsftpd.8 vsftpd-1.1.3/vsftpd.8
+--- vsftpd-1.1.3.orig/vsftpd.8 2001-03-11 20:14:07.000000000 -0500
++++ vsftpd-1.1.3/vsftpd.8 2003-02-15 11:19:48.000000000 -0500
+@@ -20,7 +20,7 @@
+ An optional
+ .Op configuration file
+ may be given on the command line. The default configuration file is
+-.Pa /etc/vsftpd.conf .
++.Pa /etc/vsftpd/vsftpd.conf .
+ .Sh SEE ALSO
+ .Xr vsftpd.conf 5
+
+diff -uNr vsftpd-1.1.3.orig/vsftpd.conf.5 vsftpd-1.1.3/vsftpd.conf.5
+--- vsftpd-1.1.3.orig/vsftpd.conf.5 2002-11-09 10:41:11.000000000 -0500
++++ vsftpd-1.1.3/vsftpd.conf.5 2003-02-15 11:19:48.000000000 -0500
+@@ -4,7 +4,7 @@
+ .SH DESCRIPTION
+ vsftpd.conf may be used to control various aspects of vsftpd's behaviour. By
+ default, vsftpd looks for this file at the location
+-.BR /etc/vsftpd.conf .
++.BR /etc/vsftpd/vsftpd.conf .
+ However, you may override this by specifying a command line argument to
+ vsftpd. The command line argument is the pathname of the configuration file
+ for vsftpd. This behaviour is useful because you may wish to use an advanced
+@@ -115,7 +115,7 @@
+ different if chroot_local_user is set to YES. In this case, the list becomes
+ a list of users which are NOT to be placed in a chroot() jail.
+ By default, the file containing this list is
+-/etc/vsftpd.chroot_list, but you may override this with the
++/etc/vsftpd/vsftpd.chroot_list, but you may override this with the
+ .BR chroot_list_file
+ setting.
+
+@@ -143,7 +143,7 @@
+ .B deny_email_enable
+ If activated, you may provide a list of anonymous password e-mail responses
+ which cause login to be denied. By default, the file containing this list is
+-/etc/vsftpd.banned_emails, but you may override this with the
++/etc/vsftpd/vsftpd.banned_emails, but you may override this with the
+ .BR banned_email_file
+ setting.
+
+@@ -316,7 +316,7 @@
+ .TP
+ .B xferlog_enable
+ If enabled, a log file will be maintained detailling uploads and downloads.
+-By default, this file will be placed at /var/log/vsftpd.log, but this location
++By default, this file will be placed at /var/log/vsftpd/vsftpd.log, but this location
+ may be overridden using the configuration setting
+ .BR xferlog_file .
+
+@@ -448,7 +448,7 @@
+ .BR deny_email_enable
+ is enabled.
+
+-Default: /etc/vsftpd.banned_emails
++Default: /etc/vsftpd/vsftpd.banned_emails
+ .TP
+ .B banner_file
+ This option is the name of a file containing text to display when someone
+@@ -476,7 +476,7 @@
+ .BR chroot_local_user
+ is disabled.
+
+-Default: /etc/vsftpd.chroot_list
++Default: /etc/vsftpd/vsftpd.chroot_list
+ .TP
+ .B guest_username
+ See the boolean setting
+@@ -530,7 +530,7 @@
+ .B pam_service_name
+ This string is the name of the PAM service vsftpd will use.
+
+-Default: ftp
++Default: vsftpd
+ .TP
+ .B pasv_address
+ Use this option to override the IP address that vsftpd will advertise in
+@@ -543,7 +543,7 @@
+ directory should not be writable by the ftp user. This directory is used
+ as a secure chroot() jail at times vsftpd does not require filesystem access.
+
+-Default: /usr/share/empty
++Default: /usr/share/vsftpd/empty
+ .TP
+ .B user_config_dir
+ This powerful option allows the override of any config option specified in
+@@ -551,10 +551,10 @@
+ with an example. If you set
+ .BR user_config_dir
+ to be
+-.BR /etc/vsftpd_user_conf
++.BR /etc/vsftpd/vsftpd_user_conf
+ and then log on as the user "chris", then vsftpd will apply the settings in
+ the file
+-.BR /etc/vsftpd_user_conf/chris
++.BR /etc/vsftpd/vsftpd_user_conf/chris
+ for the duration of the session. The format of this file is as detailed in
+ this manual page!
+
+@@ -565,7 +565,7 @@
+ .BR userlist_enable
+ option is active.
+
+-Default: /etc/vsftpd.user_list
++Default: /etc/vsftpd/vsftpd.user_list
+ .TP
+ .B xferlog_file
+ This option is the name of the file to which we write the transfer log. The
+@@ -573,7 +573,7 @@
+ .BR xferlog_enable
+ is set.
+
+-Default: /var/log/vsftpd.log
++Default: /var/log/vsftpd/vsftpd.log
+
+ .SH AUTHOR
+ chris@scary.beasts.org
diff --git a/net-ftp/vsftpd/vsftpd-1.1.3.ebuild b/net-ftp/vsftpd/vsftpd-1.1.3.ebuild
new file mode 100644
index 000000000000..4e5d64c70854
--- /dev/null
+++ b/net-ftp/vsftpd/vsftpd-1.1.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/vsftpd/vsftpd-1.1.3.ebuild,v 1.1 2003/02/15 16:43:43 woodchip Exp $
+
+IUSE="pam tcpd"
+
+DESCRIPTION="Very Secure FTP Daemon written with speed, size and security in mind"
+SRC_URI="ftp://vsftpd.beasts.org/users/cevans/${P}.tar.gz"
+HOMEPAGE="http://vsftpd.beasts.org/"
+DEPEND="pam? ( >=sys-libs/pam-0.75 ) tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+RDEPEND="|| ( sys-apps/xinetd >=sys-apps/ucspi-tcp-0.88-r3 )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ patch -p1 <${FILESDIR}/${P}-gentoo.diff || die
+ use tcpd && echo '#define VSF_BUILD_TCPWRAPPERS' >> builddefs.h
+}
+
+src_compile() {
+ if use pam; then
+ emake CFLAGS="${CFLAGS} -DUSE_PAM" || die
+ else
+ emake CFLAGS="${CFLAGS}" \
+ LIBS='`./vsf_findlibs.sh | sed "/[/-]\<.*pam.*\>/d"`' || die
+ fi
+}
+
+src_install() {
+ into /usr
+ doman vsftpd.conf.5 vsftpd.8
+ dosbin vsftpd
+
+ dodoc AUDIT BENCHMARKS BUGS Changelog FAQ INSTALL \
+ LICENSE README README.security REWARD SIZE \
+ SPEED TODO TUNING
+ newdoc ${FILESDIR}/vsftpd.conf vsftpd.conf.sample
+ newdoc vsftpd.conf vsftpd.conf.dist.sample
+ docinto security ; dodoc SECURITY/*
+ cp -a EXAMPLE ${D}/usr/share/doc/${PF}/examples
+ chown -R root.root ${D}/usr/share/doc/${PF} # :\
+
+ insinto /etc ; doins ${FILESDIR}/ftpusers
+ insinto /etc/vsftpd ; newins ${FILESDIR}/vsftpd.conf vsftpd.conf.sample
+ insinto /etc/xinetd.d ; newins ${FILESDIR}/vsftpd.xinetd vsftpd
+ insinto /etc/pam.d ; newins ${FILESDIR}/vsftpd.pam vsftpd
+}
+
+pkg_postinst() {
+ # empty dirs...
+ install -m0755 -o root -g root -d ${ROOT}/home/ftp
+ install -m0755 -o root -g root -d ${ROOT}/usr/share/vsftpd/empty
+ install -m0755 -o root -g root -d ${ROOT}/var/log/vsftpd
+}