summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-07-14 09:12:19 +0000
committerRoy Marples <uberlord@gentoo.org>2006-07-14 09:12:19 +0000
commit475aa9f0308c8c23e08778dea216ce2d45fa88c6 (patch)
tree0c5f142a7b9cfb98dcf734f6c1ff046f7c0686ca /net-ftp/vsftpd/vsftpd-2.0.5.ebuild
parentRevision bump; hibernate-scripts is trying to echo to an read-only file; meta... (diff)
downloadhistorical-475aa9f0308c8c23e08778dea216ce2d45fa88c6.tar.gz
historical-475aa9f0308c8c23e08778dea216ce2d45fa88c6.tar.bz2
historical-475aa9f0308c8c23e08778dea216ce2d45fa88c6.zip
Version bump
Package-Manager: portage-2.1.1_pre2-r8
Diffstat (limited to 'net-ftp/vsftpd/vsftpd-2.0.5.ebuild')
-rw-r--r--net-ftp/vsftpd/vsftpd-2.0.5.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/net-ftp/vsftpd/vsftpd-2.0.5.ebuild b/net-ftp/vsftpd/vsftpd-2.0.5.ebuild
new file mode 100644
index 000000000000..9d65c5105b77
--- /dev/null
+++ b/net-ftp/vsftpd/vsftpd-2.0.5.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/vsftpd/vsftpd-2.0.5.ebuild,v 1.1 2006/07/14 09:12:19 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="Very Secure FTP Daemon written with speed, size and security in mind"
+HOMEPAGE="http://vsftpd.beasts.org/"
+SRC_URI="ftp://vsftpd.beasts.org/users/cevans/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="caps logrotate pam tcpd ssl selinux xinetd"
+
+DEPEND="caps? ( sys-libs/libcap )
+ pam? ( || ( virtual/pam sys-libs/pam ) )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+"
+RDEPEND="${DEPEND}
+ net-ftp/ftpbase
+ logrotate? ( app-admin/logrotate )
+ selinux? ( sec-policy/selinux-ftpd )
+ xinetd? ( sys-apps/xinetd )
+"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Patch the source, config and the manpage to use /etc/vsftpd/
+ epatch "${FILESDIR}/vsftpd-2.0.3-gentoo.patch"
+
+ # Configure vsftpd build defaults
+ use tcpd && echo "#define VSF_BUILD_TCPWRAPPERS" >> builddefs.h
+ use ssl && echo "#define VSF_BUILD_SSL" >> builddefs.h
+ use pam || echo "#undef VSF_BUILD_PAM" >> builddefs.h
+
+ # Ensure that we don't link against libcap unless asked
+ if ! use caps ; then
+ sed -i '/^#define VSF_SYSDEP_HAVE_LIBCAP$/ d' sysdeputil.c
+ sed -i '/libcap/ d' vsf_findlibs.sh
+ fi
+
+ # Let portage control stripping
+ sed -i '/^LINK[[:space:]]*=[[:space:]]*/ s/-Wl,-s//' Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ into /usr
+ doman vsftpd.conf.5 vsftpd.8
+ dosbin vsftpd
+
+ dodoc AUDIT BENCHMARKS BUGS Changelog FAQ \
+ LICENSE README README.security REWARD SIZE \
+ SPEED TODO TUNING
+ newdoc vsftpd.conf vsftpd.conf.example
+
+ docinto security
+ dodoc SECURITY/*
+
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r EXAMPLE/*
+
+ insinto /etc/vsftpd
+ newins vsftpd.conf vsftpd.conf.example
+
+ if use logrotate ; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/vsftpd.logrotate" vsftpd
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/vsftpd.xinetd" vsftpd
+ fi
+
+ newinitd "${FILESDIR}/vsftpd.init" vsftpd
+
+ keepdir /usr/share/vsftpd/empty
+}
+
+pkg_preinst() {
+ # If we use xinetd, then we comment out listen=YES
+ # so that our default config works under xinetd - fixes #78347
+ if use xinetd ; then
+ sed -i '/\listen=YES/s/^/#/g' ${IMAGE}/etc/vsftpd/vsftpd.conf.example
+ fi
+}
+
+pkg_postinst() {
+ einfo "vsftpd init script can now be multiplexed."
+ einfo "The default init script forces /etc/vsftpd/vsftpd.conf to exist."
+ einfo "If you symlink the init script to another one, say vsftpd.foo"
+ einfo "then that uses /etc/vsftpd/foo.conf instead."
+ einfo
+ einfo "Example:"
+ einfo " cd /etc/init.d"
+ einfo " ln -s vsftpd vsftpd.foo"
+ einfo "You can now treat vsftpd.foo like any other service"
+}