summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-10 16:30:16 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-10 16:30:16 +0000
commit8b93216efc2344ca4e0958726c1fb82cd9c3c22b (patch)
tree9d366de932efe3fee72e88b5e7fba710022845da /net-ftp/lftp
parentmodified keywords (diff)
downloadhistorical-8b93216efc2344ca4e0958726c1fb82cd9c3c22b.tar.gz
historical-8b93216efc2344ca4e0958726c1fb82cd9c3c22b.tar.bz2
historical-8b93216efc2344ca4e0958726c1fb82cd9c3c22b.zip
version bump.
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.01
-rw-r--r--net-ftp/lftp/lftp-2.6.0.ebuild48
3 files changed, 56 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index f19762feb7df..c37b0b6ac69a 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.4 2002/08/04 23:30:04 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.5 2002/08/10 16:30:16 raker Exp $
+
+*lftp-2.6.0 (10 Aug 2002)
+
+ 10 Aug 2002; Nick Hadaway <raker@gentoo.org>
+ lftp-2.6.0.ebuild, files/digest-lftp-2.6.0 :
+ Version bump.
*lftp-2.5.4-r1 (05 Jul 2002)
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.0 b/net-ftp/lftp/files/digest-lftp-2.6.0
new file mode 100644
index 000000000000..9d907930f946
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.0
@@ -0,0 +1 @@
+MD5 c52aaca87c2a9fbc71cc9fd027af0b32 lftp-2.6.0.tar.bz2 1124131
diff --git a/net-ftp/lftp/lftp-2.6.0.ebuild b/net-ftp/lftp/lftp-2.6.0.ebuild
new file mode 100644
index 000000000000..c39c5d25a6ed
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.0.ebuild,v 1.1 2002/08/10 16:30:16 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LFTP is a sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}