summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-02-09 16:50:08 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-02-09 16:50:08 +0000
commit084fce4016e62b05308c6ebb03f21d179998a008 (patch)
tree73aa5c6a99eb1b558324a9a148e4af72f2177888 /net-firewall/firestarter
parentSlight fix to inits and ChangeLog. Bug #15004 (diff)
downloadhistorical-084fce4016e62b05308c6ebb03f21d179998a008.tar.gz
historical-084fce4016e62b05308c6ebb03f21d179998a008.tar.bz2
historical-084fce4016e62b05308c6ebb03f21d179998a008.zip
Moved from net-misc to net-firewall
Diffstat (limited to 'net-firewall/firestarter')
-rw-r--r--net-firewall/firestarter/files/digest-firestarter-0.8.21
-rw-r--r--net-firewall/firestarter/files/digest-firestarter-0.8.31
-rw-r--r--net-firewall/firestarter/files/digest-firestarter-0.9.01
-rw-r--r--net-firewall/firestarter/files/digest-firestarter-0.9.11
-rw-r--r--net-firewall/firestarter/firestarter-0.8.2.ebuild41
-rw-r--r--net-firewall/firestarter/firestarter-0.8.3.ebuild45
-rw-r--r--net-firewall/firestarter/firestarter-0.9.0.ebuild41
-rw-r--r--net-firewall/firestarter/firestarter-0.9.1.ebuild41
8 files changed, 172 insertions, 0 deletions
diff --git a/net-firewall/firestarter/files/digest-firestarter-0.8.2 b/net-firewall/firestarter/files/digest-firestarter-0.8.2
new file mode 100644
index 000000000000..07b72c08bece
--- /dev/null
+++ b/net-firewall/firestarter/files/digest-firestarter-0.8.2
@@ -0,0 +1 @@
+MD5 80e101dc3b5d8ba0f539e26d08ef829d firestarter-0.8.2.tar.gz 678372
diff --git a/net-firewall/firestarter/files/digest-firestarter-0.8.3 b/net-firewall/firestarter/files/digest-firestarter-0.8.3
new file mode 100644
index 000000000000..389f20ccdf48
--- /dev/null
+++ b/net-firewall/firestarter/files/digest-firestarter-0.8.3
@@ -0,0 +1 @@
+MD5 4df412f0d6da3787d357049a106685ac firestarter-0.8.3.tar.gz 686835
diff --git a/net-firewall/firestarter/files/digest-firestarter-0.9.0 b/net-firewall/firestarter/files/digest-firestarter-0.9.0
new file mode 100644
index 000000000000..9a6f060da830
--- /dev/null
+++ b/net-firewall/firestarter/files/digest-firestarter-0.9.0
@@ -0,0 +1 @@
+MD5 f3782dd044d59251ea47c21cd99fbd9b firestarter-0.9.0.tar.gz 471467
diff --git a/net-firewall/firestarter/files/digest-firestarter-0.9.1 b/net-firewall/firestarter/files/digest-firestarter-0.9.1
new file mode 100644
index 000000000000..56ab7de1427f
--- /dev/null
+++ b/net-firewall/firestarter/files/digest-firestarter-0.9.1
@@ -0,0 +1 @@
+MD5 d2b2b22182a340e2bd06a94d4800d26c firestarter-0.9.1.tar.gz 628274
diff --git a/net-firewall/firestarter/firestarter-0.8.2.ebuild b/net-firewall/firestarter/firestarter-0.8.2.ebuild
new file mode 100644
index 000000000000..18188460a976
--- /dev/null
+++ b/net-firewall/firestarter/firestarter-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.8.2.ebuild,v 1.1 2003/02/09 16:50:08 mholzer Exp $
+
+IUSE="nls"
+
+#MY_P=firestarter-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="Gui for firewalls (iptables & ipchains), and a firewall monitor."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://firestarter.sf.net"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.4
+ <gnome-base/gnome-panel-2
+ sys-apps/iptables"
+RDEPEND="nls? ( sys-devel/gettext )"
+SLOT="0"
+
+src_compile() {
+
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ einstall destdir=${D} graphicsdir=${D}/usr/share/pixmaps || die "einstall failed"
+ dodoc AUTHORS Changelog README TODO
+
+}
+
+pkg_postinstall() {
+ ./postinstall
+}
diff --git a/net-firewall/firestarter/firestarter-0.8.3.ebuild b/net-firewall/firestarter/firestarter-0.8.3.ebuild
new file mode 100644
index 000000000000..f7f2c330a284
--- /dev/null
+++ b/net-firewall/firestarter/firestarter-0.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.8.3.ebuild,v 1.1 2003/02/09 16:50:08 mholzer Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gui for firewalls (iptables & ipchains), and a firewall monitor."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://firestarter.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.4
+ <gnome-base/gnome-panel-2
+ sys-apps/iptables"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ einstall \
+ destdir=${D} \
+ graphicsdir=${D}/usr/share/pixmaps || die "einstall failed"
+
+ dodoc AUTHORS Changelog README TODO
+
+}
+
+pkg_postinstall() {
+ ./postinstall
+}
diff --git a/net-firewall/firestarter/firestarter-0.9.0.ebuild b/net-firewall/firestarter/firestarter-0.9.0.ebuild
new file mode 100644
index 000000000000..9f94f8a97278
--- /dev/null
+++ b/net-firewall/firestarter/firestarter-0.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.9.0.ebuild,v 1.1 2003/02/09 16:50:08 mholzer Exp $
+
+IUSE="nls"
+
+#MY_P=firestarter-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="Gui for firewalls (iptables & ipchains), and a firewall monitor."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://firestarter.sf.net"
+LICENSE="GPL-2"
+
+DEPEND="x11-libs/gtk+
+ gnome-base/libgnomeui
+ gnome-base/libgnome
+ sys-apps/iptables
+ nls? ( sys-devel/gettext )"
+SLOT="0"
+KEYWORDS="x86 ppc sparc "
+
+src_compile() {
+
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ einstall destdir=${D} graphicsdir=${D}/usr/share/pixmaps || die "einstall failed"
+ dodoc AUTHORS Changelog README TODO
+
+}
+
+pkg_postinstall() {
+ ./postinstall
+}
diff --git a/net-firewall/firestarter/firestarter-0.9.1.ebuild b/net-firewall/firestarter/firestarter-0.9.1.ebuild
new file mode 100644
index 000000000000..862f9b1e9625
--- /dev/null
+++ b/net-firewall/firestarter/firestarter-0.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firestarter/firestarter-0.9.1.ebuild,v 1.1 2003/02/09 16:50:08 mholzer Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gui for iptables firewall setup and monitor."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://firestarter.sf.net"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnome-2
+ sys-apps/iptables"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.21"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall destdir=${D} graphicsdir=${D}/usr/share/pixmaps || die "einstall failed"
+ dodoc AUTHORS Changelog COPYING CREDITS INSTALL README TODO
+}
+
+pkg_postinstall() {
+ ./postinstall
+}