summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 16:35:24 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 16:35:24 +0000
commitcc1ec80aa917738ea01e06cb5d33e8fa0c7bd705 (patch)
tree09ebf528c07e076983b101a11c5b00db45c24fd0 /net-dialup/ppp
parent*** empty log message *** (diff)
downloadhistorical-cc1ec80aa917738ea01e06cb5d33e8fa0c7bd705.tar.gz
historical-cc1ec80aa917738ea01e06cb5d33e8fa0c7bd705.tar.bz2
historical-cc1ec80aa917738ea01e06cb5d33e8fa0c7bd705.zip
*** empty log message ***
Diffstat (limited to 'net-dialup/ppp')
-rw-r--r--net-dialup/ppp/files/digest2
-rw-r--r--net-dialup/ppp/ppp-2.4.0-r1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/net-dialup/ppp/files/digest b/net-dialup/ppp/files/digest
new file mode 100644
index 000000000000..ec52b3709f6d
--- /dev/null
+++ b/net-dialup/ppp/files/digest
@@ -0,0 +1,2 @@
+MD5 19a66712b5ed6b752d467da919c29e50 ppp-2.4.0.tar.gz
+MD5 9542214a4fa3bc2e446c1bb41f01e45c pppoed0.47.tgz
diff --git a/net-dialup/ppp/ppp-2.4.0-r1.ebuild b/net-dialup/ppp/ppp-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..077bdf26c52f
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.0-r1.ebuild,v 1.1 2000/08/08 16:35:24 achim Exp $
+
+P="ppp-2.4.0"
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+CATEGORY="net-dialup"
+DESCRIPTION="Point-to-point protocol - used for communicating with your ISP"
+SRC_URI="ftp://ftp.linuxcare.com.au/pub/ppp/${A}"
+src_unpack() {
+
+ unpack ppp-2.4.0.tar.gz
+ cd ${S}
+
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --prefix=/usr
+ #fix Makefiles to compile optimized
+ cd ${S}
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" -e "s/LIBS =/LIBS = -lcrypt/" Makefile.orig > Makefile
+ cd ../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O:COPTS = ${CFLAGS}:" Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+ export CC=gcc
+ make
+}
+
+src_install() {
+ into /usr
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+ dodir /etc/ppp
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+}
+
+