summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-01-23 12:19:37 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-01-23 12:19:37 +0000
commit6c2080a8588e3d4ddeaa2af22b8e034000551150 (patch)
tree9c510ce4984dd4b97dbf05a3978ad05e250402f5 /net-dialup/mgetty/mgetty-1.1.30.ebuild
parentInserted upstream-patch for amd64. See bug #36676. (diff)
downloadhistorical-6c2080a8588e3d4ddeaa2af22b8e034000551150.tar.gz
historical-6c2080a8588e3d4ddeaa2af22b8e034000551150.tar.bz2
historical-6c2080a8588e3d4ddeaa2af22b8e034000551150.zip
change group phone to fax in voice.conf-dist and add group fax to the system
Diffstat (limited to 'net-dialup/mgetty/mgetty-1.1.30.ebuild')
-rw-r--r--net-dialup/mgetty/mgetty-1.1.30.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-dialup/mgetty/mgetty-1.1.30.ebuild b/net-dialup/mgetty/mgetty-1.1.30.ebuild
index 0b92b0e874ba..af713a93b7b9 100644
--- a/net-dialup/mgetty/mgetty-1.1.30.ebuild
+++ b/net-dialup/mgetty/mgetty-1.1.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.30.ebuild,v 1.8 2004/01/15 03:49:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.30.ebuild,v 1.9 2004/01/23 12:19:24 lanius Exp $
inherit flag-o-matic eutils
@@ -20,6 +20,11 @@ LICENSE="GPL-2"
KEYWORDS="x86 sparc ~alpha ~ia64"
IUSE="doc"
+pkg_setup() {
+ enewgroup fax
+ enewuser fax -1 /bin/false /dev/null fax
+}
+
src_unpack() {
unpack ${A}
@@ -32,6 +37,7 @@ src_unpack() {
-e 's:\/\* \(\#define CNDFILE "dialin.config"\) \*\/:\1:' \
-e 's:\(\#define FAX_NOTIFY_PROGRAM\).*:\1 "/etc/mgetty+sendfax/new_fax":' \
policy.h-dist > policy.h
+ sed -i -e "s:phone_group phone:phone_group fax:g" voice/voice.conf-dist
}
src_compile() {
@@ -63,8 +69,6 @@ src_compile() {
}
src_install () {
- enewuser fax
-
dodir /var/spool
dodir /usr/share/info
make prefix=${D}/usr \