summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-03-24 15:26:00 +0000
committerAlin Năstac <mrness@gentoo.org>2005-03-24 15:26:00 +0000
commit4b88f1a14eb69025330ccd5f61e6c74131a4d3e2 (patch)
treeb25f688f182a9edd155302fadf8268a8180826cf /net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild
parentMasked mmxext on SPARC since people don't know how to implement architecture ... (diff)
downloadhistorical-4b88f1a14eb69025330ccd5f61e6c74131a4d3e2.tar.gz
historical-4b88f1a14eb69025330ccd5f61e6c74131a4d3e2.tar.bz2
historical-4b88f1a14eb69025330ccd5f61e6c74131a4d3e2.zip
segfault on kernels >= 2.6.10 (#86331)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild')
-rw-r--r--net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild b/net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild
new file mode 100644
index 000000000000..1b451d888f98
--- /dev/null
+++ b/net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/intel-536ep/intel-536ep-4.69-r1.ebuild,v 1.1 2005/03/24 15:26:00 mrness Exp $
+
+inherit eutils flag-o-matic linux-mod
+
+DESCRIPTION="Driver for Intel 536EP modem"
+HOMEPAGE="http://developer.intel.com/design/modems/products/536ep.htm"
+SRC_URI="ftp://aiedownload.intel.com/df-support/6497/eng/${P}.tgz"
+
+LICENSE="Intel"
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/intel-536EP-2.56.76.0
+MODULE_NAMES="Intel536(:${S}/coredrv)"
+
+pkg_setup() {
+ if kernel_is 2 4; then
+ BUILD_TARGETS="536core"
+ BUILD_PARAMS="KERNEL_SOURCE_PATH=${KV_DIR} TARGET=TARGET_SELAH"
+ else
+ BUILD_TARGETS="536core_26"
+ BUILD_PARAMS="KERNEL_SOURCE_PATH=${KV_DIR}"
+ fi
+
+ linux-mod_pkg_setup
+}
+
+src_unpack(){
+ unpack ${A}
+
+ cd ${S}
+ if kernel_is 2 4; then
+ #there is no way of passing this as make parameter
+ sed -i -e 's/\$(PSTN_DEF)/-DTARGET_SELAH -DTARGET_LINUX -DLINUX/' coredrv/Makefile
+ elif kernel_is ge 2 6 10; then
+ #see bug #86331
+ epatch ${FILESDIR}/${P}-kernel-2.6.10-tty.patch
+
+ if kernel_is ge 2 6 11; then
+ #addapt to power management changes occured in kernel
+ epatch ${FILESDIR}/${P}-kernel-2.6.11-pm.patch
+ fi
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ #install hamregistry executable
+ exeinto /usr/sbin
+ doexe ${S}/hamregistry
+
+ #install boot script and config
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/intel536ep.initd intel536ep
+ insinto /etc/conf.d
+ newins ${FILESDIR}/intel536ep.confd intel536ep
+}