summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 06:44:16 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 06:44:16 +0000
commit6f83b200c1edda99fc3b6bcb7146225e6b27e661 (patch)
tree22cebed43a34c4b1e4962c89e7f1d85076d3d16d /net-analyzer
parentcategory move dev-util/gputils to dev-embedded/gputils (diff)
downloadhistorical-6f83b200c1edda99fc3b6bcb7146225e6b27e661.tar.gz
historical-6f83b200c1edda99fc3b6bcb7146225e6b27e661.tar.bz2
historical-6f83b200c1edda99fc3b6bcb7146225e6b27e661.zip
Add experimental perl support. Fixes bugs 29603 and 30439.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/ChangeLog7
-rw-r--r--net-analyzer/net-snmp/Manifest4
-rw-r--r--net-analyzer/net-snmp/files/digest-net-snmp-5.0.9-r21
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.0.9-r2.ebuild68
4 files changed, 78 insertions, 2 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index 0496ef7adaae..cfdc115bd3b1 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.25 2003/10/20 05:25:09 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.26 2003/10/20 06:44:15 max Exp $
+
+*net-snmp-5.0.9-r2 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> net-snmp-5.0.9-r2.ebuild:
+ Add experimental perl support. Fixes bugs 29603 and 30439.
19 Oct 2003; Max Kalika <max@gentoo.org> net-snmp-5.0.9-r1.ebuild:
Add ucd-snmp/dlmod MIB support. Fixes bug 31217.
diff --git a/net-analyzer/net-snmp/Manifest b/net-analyzer/net-snmp/Manifest
index 9d1b51476b2e..f097ef38f153 100644
--- a/net-analyzer/net-snmp/Manifest
+++ b/net-analyzer/net-snmp/Manifest
@@ -1,6 +1,8 @@
MD5 67d998ad23b884a396dc092cdc04ab45 net-snmp-5.0.9-r1.ebuild 1630
-MD5 97b888ca2d455a36bb69893e9d70539d ChangeLog 4438
+MD5 3d3432244f1f5a6bb50e70f29a5b5cee net-snmp-5.0.9-r2.ebuild 1969
+MD5 39c907ac1f0154f66826bcdc8117a73f ChangeLog 4603
MD5 9384ae7ba3e9f56b8027ea92f607042d metadata.xml 215
MD5 8cadda02e3a8f7279f531b660164c310 files/digest-net-snmp-5.0.9-r1 67
+MD5 8cadda02e3a8f7279f531b660164c310 files/digest-net-snmp-5.0.9-r2 67
MD5 183ae5320f0a2d1d22f8403e0df1cce1 files/snmpd.conf 313
MD5 b27fac50a820be08480c04732666deb8 files/snmpd.rc6 485
diff --git a/net-analyzer/net-snmp/files/digest-net-snmp-5.0.9-r2 b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.9-r2
new file mode 100644
index 000000000000..6c16ce856e79
--- /dev/null
+++ b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.9-r2
@@ -0,0 +1 @@
+MD5 cecd5ec74f5c546c1ea7ed7987b5932b net-snmp-5.0.9.tar.gz 2345822
diff --git a/net-analyzer/net-snmp/net-snmp-5.0.9-r2.ebuild b/net-analyzer/net-snmp/net-snmp-5.0.9-r2.ebuild
new file mode 100644
index 000000000000..3167e4847777
--- /dev/null
+++ b/net-analyzer/net-snmp/net-snmp-5.0.9-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.9-r2.ebuild,v 1.1 2003/10/20 06:44:15 max Exp $
+
+DESCRIPTION="Software for generating and retrieving SNMP data."
+HOMEPAGE="http://net-snmp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~hppa ~alpha"
+IUSE="perl ssl ipv6 tcpd"
+
+PROVIDE="virtual/snmp"
+DEPEND="virtual/glibc
+ <sys-libs/db-2
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/sed-4
+ perl? ( >=sys-devel/libperl-5.6.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )"
+RDEPEND="${DEPEND}
+ !virtual/snmp"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_enable perl embedded-perl`"
+ myconf="${myconf} `use_with ssl openssl` `use_enable -ssl internal-md5`"
+ myconf="${myconf} `use_with tcpd libwrap`"
+ myconf="${myconf} `use_enable ipv6`"
+
+ econf \
+ --with-sys-location="Unknown" \
+ --with-sys-contact="root@Unknown" \
+ --with-default-snmp-version="3" \
+ --with-mib-modules="host smux ucd-snmp/dlmod" \
+ --with-logfile=/var/log/net-snmpd.log \
+ --with-persistent-directory=/var/lib/net-snmp \
+ --enable-ucd-snmp-compatibility \
+ --enable-shared \
+ --with-zlib \
+ ${myconf}
+
+ emake -j1 || die "compile problem"
+
+ if [ "`use perl`" ] ; then
+ emake perlmodules || die "compile perl modules problem"
+ fi
+}
+
+src_install () {
+ einstall exec_prefix="${D}/usr" persistentdir="${D}/var/lib/net-snmp"
+ keepdir /etc/snmp /var/lib/net-snmp
+
+ if [ "`use perl`" ] ; then
+ make DESTDIR="${D}" perlinstall || die "make perlinstall failed"
+ else
+ rm -f "${D}/usr/bin/mib2c" "${D}/usr/bin/tkmib"
+ fi
+
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
+ newdoc EXAMPLE.conf.def EXAMPLE.conf
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/snmpd.rc6" snmpd
+ insinto /etc/conf.d
+ newins "${FILESDIR}/snmpd.conf" snmpd
+}