summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-09 18:12:08 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-09 18:12:08 +0000
commit6665fac3cf71d5c3e8aa33ca1f5429da3706dd32 (patch)
tree420345855ea368900b375e22247c558dcccfb580 /net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
parentCorrected source URL (diff)
downloadhistorical-6665fac3cf71d5c3e8aa33ca1f5429da3706dd32.tar.gz
historical-6665fac3cf71d5c3e8aa33ca1f5429da3706dd32.tar.bz2
historical-6665fac3cf71d5c3e8aa33ca1f5429da3706dd32.zip
updated upstream version
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-3.7.1.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild b/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
new file mode 100644
index 000000000000..00a8e5d489e3
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.7.1.ebuild,v 1.1 2002/05/09 18:12:08 spider Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="http://www.tcpdump.org/release/${A}
+ http://www.jp.tcpdump.org/release/${A}"
+HOMEPAGE="http://www.tcpdump.org/"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.6.9 )
+ >=net-libs/libpcap-0.6.1"
+
+RDEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.6.9 )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use ssl`" ] ; then
+ myconf="--without-crypto"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr --enable-ipv6 $myconf
+#--disable-ipv6
+ try make CCOPT="$CFLAGS"
+}
+
+src_install() {
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc README FILES VERSION CHANGES
+}
+
+
+