summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-09 22:27:48 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-09 22:27:48 +0000
commitfacbacc36de2d52731ee7b6645e62e70002ce818 (patch)
tree4a3d5b5bf129bcaafdae007ba1b2eeee53a6ee4f /net-analyzer/snortsam/snortsam-2.44.ebuild
parentOops, missed a couple keywords. :) (diff)
downloadhistorical-facbacc36de2d52731ee7b6645e62e70002ce818.tar.gz
historical-facbacc36de2d52731ee7b6645e62e70002ce818.tar.bz2
historical-facbacc36de2d52731ee7b6645e62e70002ce818.zip
2.44 version bump.
Package-Manager: portage-2.0.53
Diffstat (limited to 'net-analyzer/snortsam/snortsam-2.44.ebuild')
-rw-r--r--net-analyzer/snortsam/snortsam-2.44.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.44.ebuild b/net-analyzer/snortsam/snortsam-2.44.ebuild
new file mode 100644
index 000000000000..7946d61335f8
--- /dev/null
+++ b/net-analyzer/snortsam/snortsam-2.44.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/snortsam-2.44.ebuild,v 1.1 2006/01/09 22:27:48 vanquirius Exp $
+
+inherit eutils
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
+HOMEPAGE="http://www.snortsam.net/"
+SRC_URI="http://www.snortsam.net/files/snortsam/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.29-no-ugly----lines.diff
+}
+
+src_compile() {
+ sed -i "s: -O2 : ${CFLAGS} :" makesnortsam.sh || die "sed failed"
+ sh makesnortsam.sh || die "makesnortsam.sh failed"
+}
+
+src_install() {
+ find "${S}" -type d -name CVS -exec rm -rf {} \;
+ find "${S}" -type f -name "*.asc" -exec rm -f {} \;
+ dobin snortsam || die "dobin failed"
+ dodoc docs/* conf/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
+ einfo "Read the INSTALL file to configure snort for snortsam, and configure"
+ einfo "snortsam for your particular firewall."
+ einfo
+
+}