summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-07-15 05:57:35 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-07-15 05:57:35 +0000
commit1d675067534915f5d8e7b56b71a5112b5f4d7444 (patch)
tree46c632caefe2a6ec93d837a3f57f46e1b0aa856a /net-analyzer/netperf
parentAdded pppconfig and made it depend on ppp-2.4.1-r2 which contains a few (diff)
downloadhistorical-1d675067534915f5d8e7b56b71a5112b5f4d7444.tar.gz
historical-1d675067534915f5d8e7b56b71a5112b5f4d7444.tar.bz2
historical-1d675067534915f5d8e7b56b71a5112b5f4d7444.zip
more fun stuff to tinker with
Diffstat (limited to 'net-analyzer/netperf')
-rw-r--r--net-analyzer/netperf/files/digest-netperf-2.21
-rw-r--r--net-analyzer/netperf/files/netperf-2.2alpha.diff20
-rw-r--r--net-analyzer/netperf/netperf-2.2.ebuild36
3 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/netperf/files/digest-netperf-2.2 b/net-analyzer/netperf/files/digest-netperf-2.2
new file mode 100644
index 000000000000..dac60ade1488
--- /dev/null
+++ b/net-analyzer/netperf/files/digest-netperf-2.2
@@ -0,0 +1 @@
+MD5 78877b60fbcddada6ffc67d6394f650a netperf-2.2alpha.tar.gz
diff --git a/net-analyzer/netperf/files/netperf-2.2alpha.diff b/net-analyzer/netperf/files/netperf-2.2alpha.diff
new file mode 100644
index 000000000000..ea13beef219b
--- /dev/null
+++ b/net-analyzer/netperf/files/netperf-2.2alpha.diff
@@ -0,0 +1,20 @@
+--- makefile.olf Sun Jul 15 00:02:19 2001
++++ makefile Sun Jul 15 00:05:18 2001
+@@ -16,7 +16,7 @@
+ # in /usr/local/netperf or /opt/netperf
+ #
+ #NETPERF_HOME = /usr/local/netperf
+-NETPERF_HOME = /opt/netperf
++NETPERF_HOME = /usr/share/netperf
+
+ # The compiler on your system might be somewhere else, and/or have
+ # a different name.
+@@ -85,7 +85,7 @@
+ # sending data using sendfile() instead of send().
+
+ LOG_FILE=DEBUG_LOG_FILE="\"/tmp/netperf.debug\""
+-CFLAGS = -Ae -O -D$(LOG_FILE) -DUSE_PSTAT -DHAVE_SENDFILE
++#CFLAGS = -DDO_UNIX
+
+ # Some platforms, and some options, require additional libraries.
+ # you can add to the "LIBS =" line to accomplish this. if you find
diff --git a/net-analyzer/netperf/netperf-2.2.ebuild b/net-analyzer/netperf/netperf-2.2.ebuild
new file mode 100644
index 000000000000..b515990aa0f8
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.2.ebuild,v 1.1 2001/07/15 05:57:35 lamer Exp $
+A=netperf-2.2alpha.tar.gz
+S=${WORKDIR}/${PN}-2.2alpha
+DESCRIPTION="This is a brief readme file for the netperf TCP/UDP/sockets/etc
+performance benchmark tools"
+SRC_URI="ftp://ftp.cup.hp.com/dist/networking/benchmarks/netperf/${A}"
+HOMEPAGE="http://www.netperf.org/"
+DEPEND=""
+
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/netperf-2.2alpha.diff
+}
+
+src_compile() {
+
+ try make
+ #try make
+}
+
+src_install () {
+
+ exeinto /usr/share/netperf
+ doexe netperf netserver tcp_range_script tcp_stream_script \
+ tcp_rr_script udp_stream_script udp_rr_script snapshot_script
+ dodoc ACKNWLDGMNTS COPYRIGHT README Release_Notes
+
+
+}
+