summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-07-24 03:31:24 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-07-24 03:31:24 +0000
commit7bd78479937975b446225e9f89112a7a92d7d113 (patch)
treee6977f2f355b351200caf3ca9a7b7d39665cd148 /net-analyzer/nessus-core/nessus-core-2.2.5.ebuild
parentStable on mips, bug #99680. (diff)
downloadhistorical-7bd78479937975b446225e9f89112a7a92d7d113.tar.gz
historical-7bd78479937975b446225e9f89112a7a92d7d113.tar.bz2
historical-7bd78479937975b446225e9f89112a7a92d7d113.zip
bug 100024
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-analyzer/nessus-core/nessus-core-2.2.5.ebuild')
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.2.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/nessus-core/nessus-core-2.2.5.ebuild b/net-analyzer/nessus-core/nessus-core-2.2.5.ebuild
new file mode 100644
index 000000000000..055f06fdb464
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-2.2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.2.5.ebuild,v 1.1 2005/07/24 03:31:18 vanquirius Exp $
+
+inherit toolchain-funcs eutils gnuconfig
+
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X tcpd gtk2 debug prelude"
+DEPEND="=net-analyzer/nessus-libraries-${PV}
+ =net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
+ X? ( virtual/x11
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ )
+ prelude? ( dev-libs/libprelude )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ gnuconfig_update
+}
+
+src_compile() {
+
+ export CC=$(tc-getCC)
+ econf `use_enable tcpd tcpwrappers` \
+ `use_enable debug` \
+ `use_enable X gtk` \
+ || die "configure failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ install || die "Install failed nessus-core"
+ cd ${S}
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+ insinto /etc/init.d
+ insopts -m 755
+ newins ${FILESDIR}/nessusd-r7 nessusd
+ keepdir /var/lib/nessus/logs
+ keepdir /var/lib/nessus/users
+ # newer version is provided by nessus-libraries
+ # should be fixed upstream in version 2.2.6
+ rm ${D}/usr/include/nessus/includes.h
+}