summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2013-07-01 10:27:33 +0000
committerHanno Boeck <hanno@gentoo.org>2013-07-01 10:27:33 +0000
commit964f320a906fa470ad221c3f304f4093d766ceaa (patch)
tree49be265d7f9c9a0139485c6c82b3c837e40b19e9 /net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild
parentopenvas-administrator: Bump, EAPI 5 port, remove old workarounds. (diff)
downloadhistorical-964f320a906fa470ad221c3f304f4093d766ceaa.tar.gz
historical-964f320a906fa470ad221c3f304f4093d766ceaa.tar.bz2
historical-964f320a906fa470ad221c3f304f4093d766ceaa.zip
greenbone-security-assistant: Bump, EAPI 5 port, remove old workarounds.
Package-Manager: portage-2.1.12.11/cvs/Linux x86_64 Manifest-Sign-Key: 0xA5880072BBB51E42
Diffstat (limited to 'net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild')
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild
new file mode 100644
index 000000000000..67184072a5b9
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild,v 1.1 2013/07/01 10:26:55 hanno Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/1335/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-6.0.0
+ dev-libs/libxslt
+ net-libs/libmicrohttpd[messages]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog CHANGES README"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLOCALSTATEDIR=${EPREFIX}/var"
+ "-DSYSCONFDIR=${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doinitd "${FILESDIR}"/gsad
+}