summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-09-29 21:02:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-09-29 21:02:03 +0000
commite9129ca0d56f01cde1e7db9142db76038b5f24dc (patch)
treeebc66531ed85f91b2febcfadf081722f06864aff /media-video
parentnew koffice which uses eclases. hooray! (diff)
downloadhistorical-e9129ca0d56f01cde1e7db9142db76038b5f24dc.tar.gz
historical-e9129ca0d56f01cde1e7db9142db76038b5f24dc.tar.bz2
historical-e9129ca0d56f01cde1e7db9142db76038b5f24dc.zip
Updated mplayer and co
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/files/digest-mplayer-0.50_pre11
-rw-r--r--media-video/mplayer/mplayer-0.50_pre1.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/media-video/mplayer/files/digest-mplayer-0.50_pre1 b/media-video/mplayer/files/digest-mplayer-0.50_pre1
new file mode 100644
index 000000000000..4265976e0cfd
--- /dev/null
+++ b/media-video/mplayer/files/digest-mplayer-0.50_pre1
@@ -0,0 +1 @@
+MD5 5a71689dda88731e1dba596e270fa3d9 MPlayer-0.50pre1.tar.bz2
diff --git a/media-video/mplayer/mplayer-0.50_pre1.ebuild b/media-video/mplayer/mplayer-0.50_pre1.ebuild
new file mode 100644
index 000000000000..0b184e09ef74
--- /dev/null
+++ b/media-video/mplayer/mplayer-0.50_pre1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Bruce Locke <blocke@shivan.org>, Martin Schlemmer <azarah@gentoo.org>
+# Donny Davies <woodchip@gentoo.org>
+# /home/cvsroot/gentoo-x86/media-video/mplayer/mplayer-0.18_pre-r1.ebuild,v 1.1 2001/09/24 06:34:22 woodchip Exp
+
+MY_P="MPlayer-0.50pre"
+S=${WORKDIR}/${MY_P}?
+A=${MY_P}1.tar.bz2
+DESCRIPTION="Media Player for Linux"
+SRC_URI="ftp://mplayerhq.hu/MPlayer/releases/${A}"
+HOMEPAGE="http://www.mplayerhq.hu"
+
+# Experimental USE flags dvd and decss
+DEPEND="virtual/glibc
+ dev-lang/nasm
+ media-libs/win32codecs
+ >=media-libs/divx4linux-20010824
+ dvd? ( media-libs/libdvdread )
+ decss? ( media-libs/libdvdcss )
+ opengl? ( media-libs/mesa )
+ sdl? ( media-libs/libsdl )
+ ggi? ( media-libs/libggi )
+ svga? ( media-libs/svgalib )
+ X? ( virtual/x11 )
+ gtk? ( x11-libs/gtk+ )
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )
+ ogg? ( media-libs/libogg )"
+
+RDEPEND="virtual/glibc
+ media-libs/win32codecs
+ >=media-libs/divx4linux-20010824
+ dvd? ( media-libs/libdvdread )
+ decss? ( media-libs/libdvdcss )
+ opengl? ( media-libs/mesa )
+ sdl? ( media-libs/libsdl )
+ ggi? ( media-libs/libggi )
+ svga? ( media-libs/svgalib )
+ X? ( virtual/x11 )
+ gtk? ( x11-libs/gtk+ )
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )
+ ogg? ( media-libs/libogg )"
+
+
+
+src_compile() {
+
+ local myconf
+ use 3dnow || myconf="${myconf} --disable-3dnow --disable-3dnowex"
+ use mmx || myconf="${myconf} --disable-mmx --disable-mmx2"
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use gtk && myconf="${myconf} --enable-gui"
+ use oss || myconf="${myconf} --disable-ossaudio"
+ use nls || myconf="${myconf} --disable-nls"
+ use opengl || myconf="${myconf} --disable-gl"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use ggi || myconf="${myconf} --disable-ggi"
+ use sse || myconf="${myconf} --disable-sse"
+ use svga || myconf="${myconf} --disable-svga"
+ use alsa || myconf="${myconf} --disable-alsa"
+ use esd || myconf="${myconf} --disable-esd"
+ use ogg || myconf="${myconf} --disable-oggvorbis"
+ use decss && myconf="${myconf} --enable-css"
+
+ ./configure --mandir=/usr/share/man --prefix=/usr --host=${CHOST} ${myconf} || die
+ make OPTFLAGS="${CFLAGS}" all || die
+
+}
+
+src_install() {
+
+ make prefix=${D}/usr/share BINDIR=${D}/usr/bin install || die
+
+ rm DOCS/*.1
+ dodir /usr/share/doc/${PF}
+ cp -a DOCS/* ${D}/usr/share/doc/${PF}
+
+ # Install a wrapper for mplayer to handle the codecs.conf
+ mv ${D}/usr/bin/mplayer ${D}/usr/bin/mplayer-bin
+ exeinto /usr/bin ; doexe ${FILESDIR}/mplayer
+
+ # This tries setting up mplayer.conf automagically
+ local video="sdl" audio="sdl"
+ if [ "`use X`" ] ; then
+ if [ "`use sdl`" ] ; then
+ video="sdl"
+ elif [ "`use ggi`" ] ; then
+ video="ggi"
+ elif [ "`use xv`" ] ; then
+ video="xv"
+ elif [ "`use dga`" ] ; then
+ video="dga"
+ elif [ "`use opengl`" ] ; then
+ video="gl"
+ else
+ video="x11"
+ fi
+ else
+ if [ "`use fbcon`" ] ; then
+ video="fbdev"
+ elif [ "`use svga`" ] ; then
+ video="svga"
+ elif [ "`use aalib`" ] ; then
+ video="aa"
+ fi
+ fi
+ if [ "`use sdl`" ] ; then
+ audio="sdl"
+ elif [ "`use alsa`" ] ; then
+ audio="alsa"
+ elif [ "`use oss`" ] ; then
+ audio="oss"
+ fi
+ sed -e "s/vo=xv/vo=${video}/" -e "s/ao=oss/ao=${audio}/" -e 's/include =/#include =/' ${S}/etc/example.conf > ${T}/mplayer.conf
+
+ insinto /etc
+ doins ${T}/mplayer.conf ${S}/etc/codecs.conf
+
+}