summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-11-28 16:19:45 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-11-28 16:19:45 +0000
commite1419dde9823ae90f1cd89df9e5b0b235ec8e2dd (patch)
treec982ce5ee9e995f80f01e2e57caa2808b2310b63 /media-video
parentFirst shot at the 1-alpha. (diff)
downloadhistorical-e1419dde9823ae90f1cd89df9e5b0b235ec8e2dd.tar.gz
historical-e1419dde9823ae90f1cd89df9e5b0b235ec8e2dd.tar.bz2
historical-e1419dde9823ae90f1cd89df9e5b0b235ec8e2dd.zip
New version. Requires xine-lib-alpha.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/xine-ui/ChangeLog7
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.151
-rw-r--r--media-video/xine-ui/xine-ui-0.9.15.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 7ae0c7a35f90..e86aa36707bc 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.19 2002/08/13 03:45:49 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.20 2002/11/28 16:19:45 agenkin Exp $
+*xine-ui-0.9.15 (28 Nov 2002)
+
+ 28 Nov 2002; Arcady Genkin <agenkin@gentoo.org> xine-ui-0.9.15.ebuild :
+ New version.
+
*xine-ui-0.9.10-r1 (06 Aug 2002)
06 Aug 2002; Seemant Kulleen <seemant@gentoo.org> xine-ui-0.9.10-r1.ebuild:
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.15 b/media-video/xine-ui/files/digest-xine-ui-0.9.15
new file mode 100644
index 000000000000..068ebb376d7f
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.15
@@ -0,0 +1 @@
+MD5 1199046da1f73247b116b5cc94d6a944 xine-ui-0.9.15.tar.gz 2771125
diff --git a/media-video/xine-ui/xine-ui-0.9.15.ebuild b/media-video/xine-ui/xine-ui-0.9.15.ebuild
new file mode 100644
index 000000000000..99bf0d263355
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.15.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.15.ebuild,v 1.1 2002/11/28 16:19:45 agenkin Exp $
+
+DESCRIPTION="Skinned front end for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_alpha2
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X aalib gnome nls directfb"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}