summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-12-13 19:05:47 +0000
committerBryon Roche <kain@gentoo.org>2002-12-13 19:05:47 +0000
commita7ed18643e82789fdd89717507cf6c84bf0e0cda (patch)
tree576267b8006aec8b665f877edac0299e65ece74a /media-video
parentSorry Guys, we had to remove 0.1.1 - 0.1.3 (diff)
downloadhistorical-a7ed18643e82789fdd89717507cf6c84bf0e0cda.tar.gz
historical-a7ed18643e82789fdd89717507cf6c84bf0e0cda.tar.bz2
historical-a7ed18643e82789fdd89717507cf6c84bf0e0cda.zip
ffmpeg isn't REALLY x86 specific. Giving ppc and sparc a nice big ~.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog8
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 406704f48bdd..bc3a1297a2e9 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for media-video/ffmpeg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.6 2002/12/13 10:59:44 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.7 2002/12/13 19:05:47 kain Exp $
-*ffmpeg-0.4.5.20021212 (12 Dec 2002)
+*ffmpeg-0.4.5.20021212 (13 Dec 2002)
+
+ 13 Dec 2002; Bryon Roche <kain@gentoo.org> ffmpeg-0.4.5.20021212.ebuild :
+ ffmpeg isn't REALLY x86 specific. Giving ppc and sparc a nice big ~.
+
12 Dec 2002; Joshua Brindle <method@gentoo.org> ffmpeg-0.4.5.20021212.ebuild :
cvs snapshot so that streaming will work, also added mp3lame and oggvorbis
support with encode and oggvorbis use vars.
diff --git a/media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild b/media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild
index 048dff3ee50f..2267da172d5d 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild,v 1.1 2002/12/13 02:16:45 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.5.20021212.ebuild,v 1.2 2002/12/13 19:05:47 kain Exp $
S=${WORKDIR}/ffmpeg
DESCRIPTION="Tool to manipulate and stream video files"
@@ -14,16 +14,16 @@ filter-flags -fforce-addr
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 -ppc -sparc "
+KEYWORDS="~x86 ~ppc ~sparc "
-DEPEND="dev-lang/nasm
+DEPEND="x86? ( dev-lang/nasm )
encode? ( >=media-sound/lame-3.92 )
oggvorbis? ( >=media-libs/libvorbis-1.0-r1 )"
src_compile() {
local myconf
- use mmx || myconf="--disable-mmx"
+ use x86 && use mmx || myconf="--disable-mmx"
use encode && myconf="${myconf} --enable-mp3lame"
use oggvorbis && myconf="${myconf} --enable-vorbis"