summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-09-18 21:15:11 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-09-18 21:15:11 +0000
commit12399a7ca5ec05e427d6e0ae4ca89c54618cfc98 (patch)
tree0218558e953e7fddd674a5620fdf81ee319aa388 /media-video
parentAdd local USE-flags for audacious-plugins. (diff)
downloadhistorical-12399a7ca5ec05e427d6e0ae4ca89c54618cfc98.tar.gz
historical-12399a7ca5ec05e427d6e0ae4ca89c54618cfc98.tar.bz2
historical-12399a7ca5ec05e427d6e0ae4ca89c54618cfc98.zip
fixed CFLAGS issue (see bug #147250), removed old versions.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/qdvdauthor/ChangeLog7
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild7
2 files changed, 11 insertions, 3 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 2386fe0ad278..84df0ce2077f 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/qdvdauthor
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.11 2006/09/15 14:04:27 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.12 2006/09/18 21:15:11 sbriesen Exp $
+
+ 18 Sep 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ -qdvdauthor-0.1.0.ebuild, -qdvdauthor-0.1.2.ebuild,
+ qdvdauthor-0.1.2-r1.ebuild:
+ fixed CFLAGS issue (see bug #147250), removed old versions.
15 Sep 2006; Stefan Briesenick <sbriesen@gentoo.org>
qdvdauthor-0.1.2-r1.ebuild:
diff --git a/media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild b/media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild
index 4acf177a258a..6a8392cec59b 100644
--- a/media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild
+++ b/media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild,v 1.2 2006/09/15 14:04:27 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.1.2-r1.ebuild,v 1.3 2006/09/18 21:15:11 sbriesen Exp $
-inherit eutils qt3
+inherit eutils flag-o-matic qt3
DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
HOMEPAGE="http://qdvdauthor.sourceforge.net/"
@@ -33,6 +33,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # do not over-optimize (see #147250)
+ replace-flags -O? -O2
+
# set our C(XX)FLAGS
for PRO in qdvdauthor/*.pro qdvdauthor/*/*.pro; do
echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> ${PRO}