summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-17 11:33:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-17 11:33:33 +0000
commite4a3f2b3fb1b42c68c869bf663c2b95491b1f3e4 (patch)
tree467a94b38983509d0dffaff968b6ea21dafa9c01 /media-video/mplayer
parentrealplayer is available -- but they're hiding it well (diff)
downloadhistorical-e4a3f2b3fb1b42c68c869bf663c2b95491b1f3e4.tar.gz
historical-e4a3f2b3fb1b42c68c869bf663c2b95491b1f3e4.tar.bz2
historical-e4a3f2b3fb1b42c68c869bf663c2b95491b1f3e4.zip
mplayer is now fetching a weekly snapshot
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/ChangeLog12
-rw-r--r--media-video/mplayer/files/digest-mplayer-0.60-r64
-rw-r--r--media-video/mplayer/files/digest-mplayer-current-0.6.04
-rw-r--r--media-video/mplayer/mplayer-0.60-r6.ebuild269
4 files changed, 288 insertions, 1 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 6fc124d19a3a..af520befac04 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/mplayer
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.8 2002/04/14 13:30:24 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.9 2002/04/17 11:33:33 seemant Exp $
+
+*mplayer-0.60-r6 (17 Apr 2002)
+
+ 17 Apr 2002; Seemant Kulleen <seemant@gentoo.org> mplayer-0.60-r6.ebuild
+ files/digest-mplayer-0.60-r6 :
+
+ This is an upgrade in a way, because it is now fetching the cvs snapshot
+ from the site. The actual 0.60 sources have been removed from the
+ SRC_URI, and they are replaced with a weekly snapshot. This is fine
+ because it offers much better performance than the old "stable" version.
*mplayer-0.60-r5 (14 Apr 2002)
diff --git a/media-video/mplayer/files/digest-mplayer-0.60-r6 b/media-video/mplayer/files/digest-mplayer-0.60-r6
new file mode 100644
index 000000000000..6d434cdda726
--- /dev/null
+++ b/media-video/mplayer/files/digest-mplayer-0.60-r6
@@ -0,0 +1,4 @@
+MD5 ec7853e068dea9ed823d9befc2b75307 MPlayer-current.tar.bz2 2134477
+MD5 ab23f8e01a860a97852b28a3b0b118da mp-arial-iso-8859-1.zip 272659
+MD5 9234ea2b1616a14cabd3933bbb87604f dxr3.patch 40778
+MD5 5e12e283eeeec6125523a6f4a60d07cf default-skin-0.1.tar.bz2 167697
diff --git a/media-video/mplayer/files/digest-mplayer-current-0.6.0 b/media-video/mplayer/files/digest-mplayer-current-0.6.0
new file mode 100644
index 000000000000..6d434cdda726
--- /dev/null
+++ b/media-video/mplayer/files/digest-mplayer-current-0.6.0
@@ -0,0 +1,4 @@
+MD5 ec7853e068dea9ed823d9befc2b75307 MPlayer-current.tar.bz2 2134477
+MD5 ab23f8e01a860a97852b28a3b0b118da mp-arial-iso-8859-1.zip 272659
+MD5 9234ea2b1616a14cabd3933bbb87604f dxr3.patch 40778
+MD5 5e12e283eeeec6125523a6f4a60d07cf default-skin-0.1.tar.bz2 167697
diff --git a/media-video/mplayer/mplayer-0.60-r6.ebuild b/media-video/mplayer/mplayer-0.60-r6.ebuild
new file mode 100644
index 000000000000..fd11621396d8
--- /dev/null
+++ b/media-video/mplayer/mplayer-0.60-r6.ebuild
@@ -0,0 +1,269 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-0.60-r6.ebuild,v 1.1 2002/04/17 11:33:33 seemant Exp $
+
+
+MY_PN=${PN/mp/MP}
+MY_PV="current"
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_PN}"
+# Only install Skin if GUI should be built (gtk in USE)
+SRC_URI="http://www.mplayerhq.hu/MPlayer/cvs/${MY_P}.tar.bz2
+ ftp://mplayerhq.hu/MPlayer/releases/mp-arial-iso-8859-1.zip
+ ftp://ftp.mplayerhq.hu/MPlayer/patches/dxr3.patch
+ gtk? ( http://www.ibiblio.org/gentoo/distfiles/default-skin-0.1.tar.bz2 )"
+
+DESCRIPTION="Media Player for Linux"
+HOMEPAGE="http://www.mplayerhq.hu/"
+
+RDEPEND="media-libs/divx4linux
+ >=media-libs/win32codecs-${PV}
+ dvd? ( media-libs/libdvdread
+ media-libs/libdvdcss )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4
+ media-libs/libpng )
+ esd? ( media-sound/esound )
+ ggi? ( media-libs/libggi )
+ sdl? ( media-libs/libsdl )
+ alsa? ( media-libs/alsa-lib )
+ svga? ( media-libs/svgalib )
+ encode? ( media-sound/lame )
+ opengl? ( virtual/opengl )
+ directfb? ( dev-libs/DirectFB )
+ oggvorbis? ( media-libs/libvorbis )"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+
+src_unpack() {
+
+ unpack ${MY_P}.tar.bz2 mp-arial-iso-8859-1.zip
+
+ mv ${MY_PN}-* ${MY_PN}
+
+ # Fix bug with the default Skin
+ use gtk && ( \
+ unpack default-skin-0.1.tar.bz2
+ cd ${WORKDIR}/default
+ patch < ${FILESDIR}/default-skin.diff || die "gtk patch failed"
+ )
+
+ use matrox && ( \
+ cd ${S}/drivers;
+ patch < ${FILESDIR}/mga_vid_devfs.patch || die "matrox patch failed"
+ )
+
+ #patch mplayer with the DXR3 patch
+ local module=""
+ local dxr=""
+ for module in `lsmod` ; do
+ if [ ${module} = "em8300" ] ; then
+ dxr=true
+ fi
+ done
+ if [ $dxr ] ; then
+ cd ${WORKDIR};
+ mv ${S} ${S}a
+ patch -p0 < ${DISTDIR}/dxr3.patch || die "dxr3 patch failed"
+ mv ${S}a ${S}
+ fi
+}
+
+src_compile() {
+
+ local myconf=""
+
+ use 3dnow \
+ || myconf="${myconf} --disable-3dnow --disable-3dnowex"
+
+ use sse \
+ || myconf="${myconf} --disable-sse --disable-sse2"
+
+ # Only disable MMX if 3DNOW or SSE is not in USE
+ ( use mmx || use 3dnow || use sse ) && ( \
+ myconf="${myconf} --disable-runtime-cpudetection"
+ ) || ( \
+ myconf="${myconf} --disable-mmx --disable-mmx2"
+ myconf="${myconf} --disable-fastmemcpy"
+ )
+
+
+ # Only disable X if gtk is not in USE
+ use X || use gtk \
+ || myconf="${myconf} --disable-x11 --disable-xv --disable-xmga"
+
+ use matrox && use X \
+ && myconf="${myconf} --enable-xmga"
+
+ use matrox \
+ && myconf="${myconf} --enable-mga"
+
+ use gtk \
+ && myconf="${myconf} --enable-gui --enable-x11 --enable-xv"
+
+ use oss \
+ || myconf="${myconf} --disable-ossaudio"
+
+ use opengl \
+ || myconf="${myconf} --disable-gl"
+
+ use sdl \
+ || myconf="${myconf} --disable-sdl"
+
+ use ggi \
+ || myconf="${myconf} --disable-ggi"
+
+ use svga \
+ || myconf="${myconf} --disable-svga"
+
+ use directfb \
+ && myconf="${myconf} --enable-fbdev --enable-directfb"
+
+ use alsa \
+ || myconf="${myconf} --disable-alsa"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-vorbis"
+
+ use encode \
+ && myconf="${myconf} --enable-mencoder --enable-tv" \
+ || myconf="${myconf} --disable-mencoder"
+
+ use dvd \
+ && myconf="${myconf} --enable-dvdread --enable-css --enable-dvdnav"
+
+ use 3dfx \
+ && myconf="${myconf} --enable-3dfx --enable-tdfxfb"
+
+ use nls \
+ && myconf="${myconf} --enable-i18n"
+
+ use nas \
+ || myconf="${myconf} --disable-straming"
+
+ # Crashes on start when compiled with most optimizations.
+ # The code have CPU detection code now, with CPU specific
+ # optimizations, so extra should not be needed and is not
+ # recommended by the authors
+ CFLAGS="" \
+ CXXFLAGS="" \
+ ./configure \
+ --prefix=/usr \
+ --enable-linux-devfs \
+ ${myconf} || die
+
+ emake all || die
+
+ ( use matrox || use 3dfx ) && ( \
+ cd drivers \
+ emake all || die
+ )
+}
+
+src_install() {
+
+ make prefix=${D}/usr/share \
+ BINDIR=${D}/usr/bin \
+ CONFDIR=${D}/usr/share/mplayer \
+ DATADIR=${D}/usr/share/mplayer \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # MAN pages are already installed ...
+ rm DOCS/*.1
+ # Install the rest of the documentation
+ dodir /usr/share/doc/${PF}
+ cp -a DOCS/* ${D}/usr/share/doc/${PF}
+ doalldocs
+
+ # Install the default Skin and Gnome menu entry
+ use gtk && ( \
+ insinto /usr/share/mplayer/Skin/default
+ doins ${WORKDIR}/default/*
+ # Permissions is fried by default
+ chmod a+rx ${D}/usr/share/mplayer/Skin/default/
+ chmod a+r ${D}/usr/share/mplayer/Skin/default/*
+
+ # Fix the symlink
+ rm -rf ${D}/usr/bin/gmplayer
+ dosym /usr/bin/mplayer /usr/bin/gmplayer
+ )
+
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${S}/Gui/mplayer/pixmaps/icon.xpm mplayer.xpm
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/mplayer.desktop
+ )
+
+ # Install the font used by OSD and the GUI
+ dodir /usr/share/mplayer/fonts
+ cp -a ${WORKDIR}/iso-8859-1/ ${D}/usr/share/mplayer/fonts
+ rm -rf ${D}/usr/share/mplayer/font
+ dosym /usr/share/mplayer/fonts/iso-8859-1/arial-14/ /usr/share/mplayer/font
+
+ # This tries setting up mplayer.conf automagically
+ local video="sdl" audio="sdl"
+ use X && (
+ use gtk && video="xv" \
+ || use sdl && video="sdl" \
+ || use xv && video="xv" \
+ || use opengl && video="gl" \
+ || use ggi && video="ggi" \
+ || use dga && video="dga" \
+ || video="x11"
+ ) || (
+ use directfb && video="fbdev" \
+ || use svga && video="svga" \
+ || use aalib && video="aa"
+ )
+
+ use sdl && audio="sdl" \
+ || use alsa && audio="alsa5" \
+ || use oss audio="oss" \
+
+ # Note to myself: do not change " into '
+ sed -e "s/vo=xv/vo=${video}/" \
+ -e "s/ao=oss/ao=${audio}/" \
+ -e 's/include =/#include =/' \
+ ${S}/etc/example.conf > ${T}/mplayer.conf
+
+ insinto /etc
+ doins ${T}/mplayer.conf
+
+ insinto /usr/share/mplayer
+ doins ${S}/etc/codecs.conf
+
+ use matrox && ( \
+ dodir /lib/modules/${KVERS}/kernel/drivers/char
+ cp ${S}/drivers/mga_vid.o ${D}/lib/modules/${KVERS}/kernel/drivers/char
+ )
+}
+
+pkg_postinst() {
+
+ echo
+ echo '######################################################################'
+ echo '# MPlayer users that are going to use the GUI, please note the #'
+ echo '# following: #'
+ echo '# #'
+ echo '# The GUI works best with mplayer -vo xv -gui, but since there is #'
+ echo '# no USE flag for XVideo, or for using the GUI, the autodetection #'
+ echo '# process cannot detect this by default (SDL will be used rather). #'
+ echo '# So, if your setup supports XVideo (xvinfo should give output), #'
+ echo '# maybe do something like: #'
+ echo '# #'
+ echo '# echo "vo = xv" >~/.mplayer/config #'
+ echo '# echo "gui = 1" >>~/.mplayer/config #'
+ echo '# #'
+ echo '# after launching mplayer for the first time. #'
+ echo '# #'
+ use gtk &>/dev/null \
+ || echo '# NB: the GUI needs "gtk" as USE flag to build. #'
+ echo '######################################################################'
+ echo
+ depmod -a
+}