summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-03 18:29:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-03 18:29:52 +0000
commit7e56f985bd6c6452191f32cc69cf4bba51c9e13a (patch)
tree1cb8c4680ea0d4c19aa34f3b2c06123055d40c5c /media-video/lxdvdrip/files
parentMarked ~x64-freebsd (diff)
downloadhistorical-7e56f985bd6c6452191f32cc69cf4bba51c9e13a.tar.gz
historical-7e56f985bd6c6452191f32cc69cf4bba51c9e13a.tar.bz2
historical-7e56f985bd6c6452191f32cc69cf4bba51c9e13a.zip
version bump
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'media-video/lxdvdrip/files')
-rw-r--r--media-video/lxdvdrip/files/lxdvdrip-1.76-makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-video/lxdvdrip/files/lxdvdrip-1.76-makefile.patch b/media-video/lxdvdrip/files/lxdvdrip-1.76-makefile.patch
new file mode 100644
index 000000000000..efebf922e2ba
--- /dev/null
+++ b/media-video/lxdvdrip/files/lxdvdrip-1.76-makefile.patch
@@ -0,0 +1,28 @@
+Index: lxdvdrip/Makefile
+===================================================================
+--- lxdvdrip.orig/Makefile
++++ lxdvdrip/Makefile
+@@ -3,13 +3,16 @@ HINWEIS0 = 'Bitte Konfigdatei in /etc mi
+ HINWEIS1 = 'Check the configuration file in /etc with the Changelog'
+ HINWEIS2 = 'Comparez le fichier de config. en /etc avec le Changelog'
+
+-all:
+- gcc -g -lm -ldvdread -lpthread -o lxdvdrip lxdvdrip.c streamanalyze.c ifo.c dvdinfo.c dvdbackup.c dvdcell.c systools.c vaporize.c dvdtools.c dvdcopy.c requant.c cputest.c tcmemcpy.c dvdformat.c badsect.c mpeg2dec.c
+- gcc -g -lm -o lxac3scan lxac3scan.c
+- cd vamps && make && cd ..
+- cd dvdbackup && make && cd ..
+- cd requant && make && cd ..
+- cd buffer && make && cd ..
++LXDVDRIP_SOURCES = lxdvdrip.c streamanalyze.c ifo.c dvdinfo.c dvdbackup.c dvdcell.c systools.c vaporize.c dvdtools.c dvdcopy.c requant.c cputest.c tcmemcpy.c dvdformat.c badsect.c mpeg2dec.c
++LXDVDRIP_OBJS = $(LXDVDRIP_SOURCES:%.c=%.o)
++
++all: lxdvdrip lxac3scan
++
++lxdvdrip: $(LXDVDRIP_OBJS)
++ $(CC) $(LDFLAGS) -o $@ $^ -lm -ldvdread -lpthread
++
++lxac3scan: lxac3scan.o
++ $(CC) $(LDFLAGS) -o $@ $^ -lm
+
+ clean:
+ rm -f lxdvdrip lxac3scan *.o