summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-25 17:09:55 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-25 17:09:55 +0000
commit417c2937a758f5e426d0d4d0d994569fa9da80b8 (patch)
tree18ed64c10e9365b06d09a7ebccebc9c078b0b864 /media-video/dvdrip/dvdrip-0.50.15.ebuild
parentVersion bumped. (diff)
downloadhistorical-417c2937a758f5e426d0d4d0d994569fa9da80b8.tar.gz
historical-417c2937a758f5e426d0d4d0d994569fa9da80b8.tar.bz2
historical-417c2937a758f5e426d0d4d0d994569fa9da80b8.zip
Version bumped.
Diffstat (limited to 'media-video/dvdrip/dvdrip-0.50.15.ebuild')
-rw-r--r--media-video/dvdrip/dvdrip-0.50.15.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-video/dvdrip/dvdrip-0.50.15.ebuild b/media-video/dvdrip/dvdrip-0.50.15.ebuild
new file mode 100644
index 000000000000..85e09a2e1f85
--- /dev/null
+++ b/media-video/dvdrip/dvdrip-0.50.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdrip/dvdrip-0.50.15.ebuild,v 1.1 2003/08/25 17:09:41 mholzer Exp $
+
+IUSE="cdr gnome"
+
+inherit perl-module
+
+MY_P=${P/dvdr/Video-DVDR}
+# Next three lines are to handle PRE versions
+MY_P=${MY_P/_pre/_}
+MY_URL="dist"
+[ "${P/pre}" != "${P}" ] && MY_URL="dist/pre"
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="dvd::rip is a graphical frontend for transcode"
+SRC_URI="http://www.exit1.org/${PN}/${MY_URL}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.exit1.org/dvdrip/"
+SLOT="0"
+LICENSE="Artistic GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=" gnome? ( gnome-extra/gtkhtml )
+ cdr? ( >=media-video/vcdimager-0.7.12
+ >=app-cdr/cdrdao-1.1.7
+ >=app-cdr/cdrtools-2.0 )
+ >=media-video/transcode-0.6.3
+ >=media-gfx/imagemagick-5.5.3
+ sys-apps/procps
+ dev-perl/gtk-perl
+ dev-perl/Storable
+ dev-perl/Event"
+
+RDEPEND=">=net-analyzer/fping-2.3
+ >=media-sound/ogmtools-0.972
+ >=media-video/mjpegtools-1.6.0
+ sys-apps/eject"
+
+src_install () {
+ perl-module_src_install
+}
+
+pkg_postinst () {
+ einfo "If you want to use the cluster-mode, you need to SUID fping"
+ einfo "chmod u+s /usr/sbin/fping"
+ einfo
+ einfo "for Perl 5.8.x you have to set PERLIO to read TOC properly"
+ einfo "for bash: export PERLIO=stdio"
+ einfo "for csh: setenv PERLIO stdio"
+ einfo "into your /.${shell}rc"
+}