summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-04 04:55:10 +0000
committerTod Neidt <tod@gentoo.org>2002-02-04 04:55:10 +0000
commit4e993a0a4491693ee41f92d239613d5e2c05cd90 (patch)
treea82f55ce01b5ec2d1e6f8f4f2dad1041062ad5e6 /media-sound
parentUpdated version (Bug 507) Thanks Arcady Genkin. (diff)
downloadhistorical-4e993a0a4491693ee41f92d239613d5e2c05cd90.tar.gz
historical-4e993a0a4491693ee41f92d239613d5e2c05cd90.tar.bz2
historical-4e993a0a4491693ee41f92d239613d5e2c05cd90.zip
Updated version (Bug 507) Thanks Arcady Genkin.
version munging, the beta suffix "a" encoded as ".1" in ebuild version. Initially package masked for further testing.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog18
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.0.1_beta10.ebuild72
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-0.9.0.1_beta101
3 files changed, 90 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 7a0040d43808..b30d3e527b43 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.1 2002/02/01 21:53:31 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.2 2002/02/04 04:55:10 tod Exp $
+
+*alsa-utils-0.9.0.1_beta10 (3 Feb 2002)
+
+ 3 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog :
+
+ Upgraded version to latest beta.
+ The issue below seems to be fixable by creating a link in the alsa-lib
+ ebuild from libasound.so.2 to libasound.so.1, but I'm leaving the warning
+ until further testing is done.
+ ##WARNING## Upgrading to this version will require massive recompiling
+ of pretty much everything linked against sound. libasound.so.1 is
+ no longer provided in the package, it is now libasound.so.2. Sound
+ apps will be broken until recompiled against the new lib. For example,
+ if you use the Gnome Desktop, you will have to recompile almost everything
+ just to start it up. Good news is you don't have to upgrade now if you
+ don't want to. Bad news is that you will eventually.
*alsa-utils-0.5.10-r7 (1 Feb 2002)
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.0.1_beta10.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.0.1_beta10.ebuild
new file mode 100644
index 000000000000..851acff3ea31
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.9.0.1_beta10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.5.10-r6.ebuild,v 1.1 2001/10/02 20:34:44 woodchip Exp
+
+
+######################## Begin version munge #########################
+#This alsa version appends a alphabetic character to the beta version.
+#Portage doesn't seem to play well with this type of tarball versioning
+#Rather than ignore this in the ebuild version, I have encoded the
+#alphabetic beta suffix as an extra number suffix on the main version,
+#i.e., alsa-utils-0.9.0beta10a --> alsa-utils-0.9.0.1_beta10
+#If subsequent alsa-0.9.0beta's are released, this ebuild should be
+#version independent, i.e alsa-utils-0.9.0beta10b --> alsa-utils-0.9.0.2_beta10
+#just requires a copy of this ebuild to the new name. If alsa releases
+#version 1.0, this silliness can end.
+#This is probably overkill, but it was fun :)
+
+#Transform P to match tarball version
+#Grab the last revision number,
+#"bs" is short for "beta suffix", not what you're thinking :)
+bs=${PV%_beta*} #wack off _beta*
+t=${bs##*.} #wack off first three numbers, save this for later
+
+#Transform to ASCII octal number of tarball beta revision suffix
+let "a=141" #The octal number for ASCII lowercase "a"
+let "bs=$t+$a-1"
+bs=$( echo -e "\\$bs" ) #convert to character
+
+MYPV="${PV/.${t}_beta/beta}${bs}"
+MYP="${PN}-${MYPV}"
+
+######################## End version Munge ##########################
+
+S=${WORKDIR}/${MYP}
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/utils/${MYP}.tar.bz2"
+
+HOMEPAGE="http://www.alsa-project.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ =media-libs/alsa-lib-0.9.0.1_beta10"
+
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install() {
+
+ ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/alsa.rc6 alsa
+
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0.1_beta10 b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0.1_beta10
new file mode 100644
index 000000000000..0e29307491c2
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0.1_beta10
@@ -0,0 +1 @@
+MD5 e525573fa6f5ae9264a206a877f391c8 alsa-utils-0.9.0beta10a.tar.bz2 85294